summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:45:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:56:03 +0200
commit4319affc9b489384c9c7cbd3a385794dbbaf8f91 (patch)
tree9ee736f40a8edc62c0c4bdf1590165f7cacbffe1 /dev-python
parentdev-python/tqdm: Remove redundant versions (diff)
downloadgentoo-4319affc9b489384c9c7cbd3a385794dbbaf8f91.tar.gz
gentoo-4319affc9b489384c9c7cbd3a385794dbbaf8f91.tar.bz2
gentoo-4319affc9b489384c9c7cbd3a385794dbbaf8f91.zip
dev-python/treq: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/treq/Manifest1
-rw-r--r--dev-python/treq/treq-17.8.0.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/treq/Manifest b/dev-python/treq/Manifest
index 40dbbb70c950..6b65bc43fc34 100644
--- a/dev-python/treq/Manifest
+++ b/dev-python/treq/Manifest
@@ -1,2 +1 @@
-DIST treq-17.8.0.tar.gz 56439 BLAKE2B 3e39c84453793baf3107c38b656c8968e593845fc0d41035b558326ff947a9e17903ce33dee3157d2cb2f79ab3aa884ddebcd52e743cd6e1ad08a0de324cd6bc SHA512 62933a512fcc8b0e77333eb9268846ad17f4b44cf6ea317ada2565054100be3caf03bda0a1becd775ec85528fc2f5ddec33d23d3579cf484a3c6ba7c71c50a7f
DIST treq-20.4.1.tar.gz 59116 BLAKE2B 1370748d8bde407a8802d54786b45fbbc65525efba14cd5a33d741573b9fca7b36629deea65672669c4da45347bb40d975a063430ffd18f50d5ef896ce6dae66 SHA512 ca24ca7ad6bcf3fe6cba490d05eea4d71727a84bb2caf0a019edc01f91f7c25d87dc8208fc7cc816d18ef42db4dc66884475f0baa6b2cf39714e4422d0d67d3b
diff --git a/dev-python/treq/treq-17.8.0.ebuild b/dev-python/treq/treq-17.8.0.ebuild
deleted file mode 100644
index 990b9483c2de..000000000000
--- a/dev-python/treq/treq-17.8.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="A requests-like API built on top of twisted.web's Agent"
-HOMEPAGE="https://github.com/twisted/treq https://pypi.org/project/treq/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/incremental[${PYTHON_USEDEP}]
-"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/twisted-16.4.0[crypt,${PYTHON_USEDEP}]
- >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
-"
-
-DEPEND="${COMMON_DEPEND}
- doc? ( dev-python/sphinx
- ${RDEPEND} )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/pep8[${PYTHON_USEDEP}]
- dev-python/httpbin[${PYTHON_USEDEP}]
- )"
-
-python_compile_all() {
- use doc && emake -C "${S}/docs" html
-}
-
-python_install_all() {
- use doc && dohtml -r "${S}/docs/_build/html/"*
- distutils-r1_python_install_all
-}
-
-test_instructions(){
- ewarn "The 'test' USE flag and FEATURE only ensures that the correct"
- ewarn "dependenciess are installed for this package."
- ewarn "Please run eg:"
- ewarn "$ python3.4 /usr/bin/trial treq"
- ewarn "as a user for each of the python versions it is installed to"
- ewarn "to correctly test this package."
-}
-
-python_test() {
- # Tests fail when run via emerge
- # they need proper network access
- test_instructions
-}