summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-20 16:33:06 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-20 16:35:56 +0100
commit460af7d01eeda8c0f7cd7e104a424e8f0758a86e (patch)
tree29ac05d973325a1d2f006ead58ebac43368d18e8 /dev-python
parentdev-python/setuptools: Version Bump (diff)
downloadgentoo-460af7d01eeda8c0f7cd7e104a424e8f0758a86e.tar.gz
gentoo-460af7d01eeda8c0f7cd7e104a424e8f0758a86e.tar.bz2
gentoo-460af7d01eeda8c0f7cd7e104a424e8f0758a86e.zip
dev-python/pip: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pip/Manifest1
-rw-r--r--dev-python/pip/pip-8.0.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index 0a63ead9ab56..3a732fa375d8 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1 +1,2 @@
DIST pip-7.1.2.tar.gz 1049170 SHA256 ca047986f0528cfa975a14fb9f7f106271d4e0c3fe1ddced6c1db2e7ae57a477 SHA512 78082afe6b559bf87f91ae9b6d304cfbfce00206e09be42fdae9d449a55cd8d968df6873e834191d0b0e6baae29e72eb3eee42386ff7c5dc9c29b6c28b754449 WHIRLPOOL 953fdc9104f3ac34c9104ec93948f58c4b0e193f18da60d3247d801c283c574490f8b91146e4278888c0b920090f537095c1a1693ca352d062dd98473390fdc9
+DIST pip-8.0.0.tar.gz 1129857 SHA256 90112b296152f270cb8dddcd19b7b87488d9e002e8cf622e14c4da9c2f6319b1 SHA512 2277dbe74af2dd3a3280b4115ebdbe2de83a5fbfdd3f15e2627441478bd08f21b46771153100ed9934a48a3662846aa84310f722029e6f56fa9a400dbd61e910 WHIRLPOOL 8f70adb37fdabf91db8c5a9d257daa8a0df0e6c6d8f077f19288033a41bca445427173bb32c4b18019096f2191b3b5d2381124c0e3a664da79bb881a0cf60610
diff --git a/dev-python/pip/pip-8.0.0.ebuild b/dev-python/pip/pip-8.0.0.ebuild
new file mode 100644
index 000000000000..aeffddf7294a
--- /dev/null
+++ b/dev-python/pip/pip-8.0.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="https://pip.pypa.io/ https://pypi.python.org/pypi/pip/ https://github.com/pypa/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+# Check pip/_vendor/vendor.txt for this
+VENDOR_DEPEND="
+ >=dev-python/distlib-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-0.9999999[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/CacheControl-0.11.5[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.12.2[${PYTHON_USEDEP}]
+ >=dev-python/progress-1.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.0[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.3.3[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.0.7[${PYTHON_USEDEP}]
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+"
+RDEPEND="${VENDOR_DEPEND}
+ >=dev-python/setuptools-19.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch
+ "${FILESDIR}"/${PN}-7.1.2-unbundle.patch
+ )
+
+python_prepare_all() {
+ mv pip/_vendor/__init__.py "${T}" || die
+ rm -r pip/_vendor/* || die
+ mv "${T}"/__init__.py pip/_vendor/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ "${PYTHON}" -m pip completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ "${PYTHON}" -m pip completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}