summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-08-21 20:22:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-08-21 20:22:12 -0400
commit483173e88cf607d2ad1d92a1fc708b352009efa5 (patch)
tree5ad7fd29b60b0eb3f7c41c53a1c7920fecaafbf1 /dev-python
parentsys-apps/elfix: remove older stable versions (diff)
downloadgentoo-483173e88cf607d2ad1d92a1fc708b352009efa5.tar.gz
gentoo-483173e88cf607d2ad1d92a1fc708b352009efa5.tar.bz2
gentoo-483173e88cf607d2ad1d92a1fc708b352009efa5.zip
dev-python/pypax: move python 3.5 support back to stable 0.9.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypax/pypax-0.9.2-r1.ebuild49
-rw-r--r--dev-python/pypax/pypax-0.9.2.ebuild4
2 files changed, 2 insertions, 51 deletions
diff --git a/dev-python/pypax/pypax-0.9.2-r1.ebuild b/dev-python/pypax/pypax-0.9.2-r1.ebuild
deleted file mode 100644
index 0bf29a4315ba..000000000000
--- a/dev-python/pypax/pypax-0.9.2-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
- inherit git-2
-else
- SRC_URI="https://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
- S="${WORKDIR}/elfix-${PV}"
-fi
-
-DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
-HOMEPAGE="https://dev.gentoo.org/~blueness/elfix/
- https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+ptpax +xtpax"
-
-REQUIRED_USE="|| ( ptpax xtpax )"
-
-RDEPEND="
- ptpax? ( dev-libs/elfutils )
- xtpax? ( sys-apps/attr )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${RDEPEND}"
-
-src_compile() {
- cd scripts
- unset PTPAX
- unset XTPAX
- use ptpax && export PTPAX="yes"
- use xtpax && export XTPAX="yes"
- distutils-r1_src_compile
-}
-
-src_install() {
- cd scripts
- distutils-r1_src_install
-}
diff --git a/dev-python/pypax/pypax-0.9.2.ebuild b/dev-python/pypax/pypax-0.9.2.ebuild
index 3122b9eaa8a3..b6937a001b64 100644
--- a/dev-python/pypax/pypax-0.9.2.ebuild
+++ b/dev-python/pypax/pypax-0.9.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
inherit distutils-r1