summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 07:55:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 08:02:54 +0200
commit48d22240202d03906cede0ee562ed75f6432cbcd (patch)
tree54d39d36d466e01fd7f2b78e471ff53542670398 /dev-python
parentdev-python/tabulate: Port to py3.9 (diff)
downloadgentoo-48d22240202d03906cede0ee562ed75f6432cbcd.tar.gz
gentoo-48d22240202d03906cede0ee562ed75f6432cbcd.tar.bz2
gentoo-48d22240202d03906cede0ee562ed75f6432cbcd.zip
dev-python/tabulate: Bump to 0.8.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tabulate/Manifest1
-rw-r--r--dev-python/tabulate/tabulate-0.8.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index aff256b19421..76b3c67e164d 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1 +1,2 @@
DIST tabulate-0.8.6.tar.gz 39420 BLAKE2B 28cd8c175b258b56a406a78d7891919a49c867d848843365605ccdcb8ba0b307f1448967a124d57b0f6264169104c9cccc84982fea666a035a265a3c9f10cc43 SHA512 ec4d7a7f20db306be1a460276e0b1b1e63fd1ca14b208a45a297508bddbc07b034e03fcb5ff67fe5e2b9419f308900675994a6dccef755c975ad0b1e9124072f
+DIST tabulate-0.8.7.tar.gz 40800 BLAKE2B 4e15ef79d152ed6a01fcc88496aed81462e2ac5c5aea1a9977eca955d3c6d743019f8c56a48ef268217cdd7c2780505c4837020ff8cb1bda442304d82e560a5c SHA512 77eb619d3115bbd574ff72b82d55e09f1e2bfe29da0b937b72930b3e65423135722bdc54bed818adf2e25cb49a58f8f85d0ca3b3ed0fcfcfda34a25e54781d0c
diff --git a/dev-python/tabulate/tabulate-0.8.7.ebuild b/dev-python/tabulate/tabulate-0.8.7.ebuild
new file mode 100644
index 000000000000..0a33126ae8f9
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.org/project/tabulate/ https://github.com/astanin/python-tabulate"
+SRC_URI="https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-${P}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python3*')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tabulate-0.8.6-avoid-pandas-dep.patch"
+)
+
+distutils_enable_tests nose