summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-06-09 11:12:57 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-06-09 11:18:47 -0700
commit4a960fb44ce532c10ab51379aa7469e9bb174aeb (patch)
tree57d315b4cfca755bf7b38801570a6f283e5bf3c6 /dev-python
parentdev-python/xdis: Version bump (diff)
downloadgentoo-4a960fb44ce532c10ab51379aa7469e9bb174aeb.tar.gz
gentoo-4a960fb44ce532c10ab51379aa7469e9bb174aeb.tar.bz2
gentoo-4a960fb44ce532c10ab51379aa7469e9bb174aeb.zip
dev-python/uncompyle6: Version Bump
Package-Manager: Portage-2.3.6_p2, Repoman-2.3.2_p70
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/uncompyle6/Manifest1
-rw-r--r--dev-python/uncompyle6/uncompyle6-2.10.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/uncompyle6/Manifest b/dev-python/uncompyle6/Manifest
index fc6199e5415c..600cd548564b 100644
--- a/dev-python/uncompyle6/Manifest
+++ b/dev-python/uncompyle6/Manifest
@@ -1 +1,2 @@
+DIST uncompyle6-2.10.1.tar.gz 831835 SHA256 0d44ea6ae48a4639cf492503e12e3dc3b782f0881ca6798cce552875405f945f SHA512 5be7c33749f3a2a02494aceebeeb2cb79bf71c39784dbe4e96cf9a5c6f02af89874bc25ba911308f01414e4ae4d9ac445864505c629d41a2c6f8b2eae2197b2b WHIRLPOOL 47e2d0a51ff497fad8f0af5af7e1b0d830bd2a9f5c359bc000a556564c9b179ad1d233614342ea86cb13087a069ee0d7adc53eef6a216fac0428fe2c659094bd
DIST uncompyle6-2.9.7.tar.gz 876996 SHA256 28b1f18a7e241b783d4cf7f36d996b35871e61544b7914c909adc3aa54ad6317 SHA512 b528a9db569f0665f78a7eef94c91e0d0d31490cb5e60f9cd2fa286c48f378875db1b5fb68e6d593c009c1ab9b381aab06a07624795177d9d72924d73d257ccc WHIRLPOOL 8735ad27678c9d0885e15ec60156272f822af43fa10173220aee0116c893e8a334d11a70030feb11d7726ae6fa9fc9e1c0e724b07d6756a49b17e90ac0f10957
diff --git a/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild b/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
new file mode 100644
index 000000000000..2e3cc7ae1c82
--- /dev/null
+++ b/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python cross-version byte-code deparser"
+HOMEPAGE="https://github.com/rocky/python-uncompyle6/ https://pypi.python.org/pypi/uncompyle6"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/xdis-3.3.1
+ <dev-python/xdis-3.4.0
+ >=dev-python/spark-parser-1.6.1
+ <dev-python/spark-parser-1.7.0"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+# only run the recommended "make check" tests
+python_test() {
+ distutils_install_for_testing
+
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ emake check || die "Tests failed under ${EPYTHON}"
+}