summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-26 00:27:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-26 00:27:18 +0200
commit4b83a4fd78270b6659debf3006d8bfccd49cee1a (patch)
treeca88667764f4572c0e7dec7c9917cafcff1804ba /dev-python
parentdev-python/ruamel-yaml-clib: Bump to 0.2.4 (diff)
downloadgentoo-4b83a4fd78270b6659debf3006d8bfccd49cee1a.tar.gz
gentoo-4b83a4fd78270b6659debf3006d8bfccd49cee1a.tar.bz2
gentoo-4b83a4fd78270b6659debf3006d8bfccd49cee1a.zip
dev-python/croniter: Bump to 1.0.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/croniter/Manifest1
-rw-r--r--dev-python/croniter/croniter-1.0.15.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/croniter/Manifest b/dev-python/croniter/Manifest
index ad52ccf8714c..85d9a23e541d 100644
--- a/dev-python/croniter/Manifest
+++ b/dev-python/croniter/Manifest
@@ -1,2 +1,3 @@
DIST croniter-1.0.12.tar.gz 38763 BLAKE2B 28bb662b05d893c782807687261b3bdafa0b1412d98dc8ceebcc0d9fff941f58b22a3abf9462c0f601bbe8701460350dad70d1239aa4f28978444698836b87b2 SHA512 ff5e35ddb0a6080ff95155de2ac5942fa1cab827a4cbb6e639553f8646b89063d0292b7fd69bc38fca90429da0272f3efeeefe0cbde0d83b9915ecb078340f08
DIST croniter-1.0.13.tar.gz 38907 BLAKE2B 436bb766c39ad61343913e354d0838458e56048115ed5d15ef95b0dc0c22b38fb4e7ec3fe6162856d208d45268fd360c8b18698b7c61bb0f70636b79a6a84988 SHA512 721749a268734e06776ab968a1fb01926f416e1a42678ee28dcac9b4655a92b5cb17984a9b9d886f8d963484f1af7382b17e72fd3998e3e1e8101fa5038a4fa1
+DIST croniter-1.0.15.tar.gz 39164 BLAKE2B daf40bcc7c791dd2a65d2cd132c380dff03353ab6d7920adddff2b1b6a87166050be6ed2b7bac5eb2b9543dcab9a4f2f65738506dc35eff0836cc591e486f885 SHA512 5aebc8a60d278acae3cef7eee6ee0ec223e44ae01b69dae601f76cb14f135547557b1417498d71a84e187dd478605efdf15355f8ad0344e459b6b40d41e994af
diff --git a/dev-python/croniter/croniter-1.0.15.ebuild b/dev-python/croniter/croniter-1.0.15.ebuild
new file mode 100644
index 000000000000..e9f104d3af45
--- /dev/null
+++ b/dev-python/croniter/croniter-1.0.15.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="https://github.com/kiorky/croniter https://pypi.org/project/croniter/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest