summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2020-11-17 22:14:49 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-22 11:11:44 +0200
commit4c6ec2c7b70f40cda50ee192b58f39c7467f801f (patch)
tree0af3e3ed524c5c6456ff2bf21303d19b7fbe3b15 /dev-python
parentdev-python/pylatex: drop old v1.3.3 (diff)
downloadgentoo-4c6ec2c7b70f40cda50ee192b58f39c7467f801f.tar.gz
gentoo-4c6ec2c7b70f40cda50ee192b58f39c7467f801f.tar.bz2
gentoo-4c6ec2c7b70f40cda50ee192b58f39c7467f801f.zip
dev-python/pylatex: vbump 1.4.1
Package-Manager: Portage-3.0.8, Repoman-2.3.23 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18309 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylatex/Manifest1
-rw-r--r--dev-python/pylatex/pylatex-1.4.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pylatex/Manifest b/dev-python/pylatex/Manifest
index af0110d4768b..772b2cf8d0ad 100644
--- a/dev-python/pylatex/Manifest
+++ b/dev-python/pylatex/Manifest
@@ -1 +1,2 @@
DIST pylatex-1.4.0.tar.gz 301148 BLAKE2B 4d1fa6add43556b7b2c1ff13b3bc2130d06018499197c3d1f40c9180f4346e774d69c2a356d5eab6c8686957ebafac71a78506553cf7cd3cd57d03c0e0ffffd1 SHA512 0d9ab3e733c50b5a4dd7a6758193645c5532c9153972bbed244e3f7e2d6a946bd36af428197f9cdd1a3256f4cc0db5dc78248973f9b330684ce8651c4a59ad91
+DIST pylatex-1.4.1.tar.gz 301482 BLAKE2B c68c8bbf70c5099b3c3146922afe94dcf4f90bfc8644fa165ee27835f4a24642645f9849f2f9fd69656dc07dcc4807869275aacf33a1e5b9c59e539801f8e821 SHA512 55a5734e4d239cef4bcaafa0ba64eea013ba3e86d137de5a5f8311d70c949d783e2e7aad24d39d16a6febbe4bddc34e47248068e1328fe3f95f39a7c7019a3a9
diff --git a/dev-python/pylatex/pylatex-1.4.1.ebuild b/dev-python/pylatex/pylatex-1.4.1.ebuild
new file mode 100644
index 000000000000..f7b9a7e488dc
--- /dev/null
+++ b/dev-python/pylatex/pylatex-1.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="PyLaTeX"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A Python library for creating LaTeX files and snippets"
+HOMEPAGE="https://github.com/JelteF/PyLaTeX"
+SRC_URI="https://github.com/JelteF/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/ordered-set[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+BDEPEND+="
+ test? (
+ dev-python/quantities[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ app-text/texlive
+ dev-texlive/texlive-latexextra
+ )"
+
+python_install_all() {
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/"${PF}"/examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "Optional dependencies:"
+ optfeature "compiling generated files" "app-text/texlive dev-texlive/texlive-latexextra dev-texlive/texlive-mathscience"
+ optfeature "matplotlib support" dev-python/matplotlib
+ optfeature "numpy support" dev-python/numpy
+ optfeature "quantities support" dev-python/quantities
+}