summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-09-20 15:19:23 +0200
committerFabian Groffen <grobian@gentoo.org>2020-09-20 15:19:35 +0200
commit4d260fb7efbf00a995bae2fe09748625c72f50cd (patch)
tree9d11e5ccdc683806b9102e4f0f546cd8604a3e32 /dev-python
parentdev-lang/spidermonkey: drop old (diff)
downloadgentoo-4d260fb7efbf00a995bae2fe09748625c72f50cd.tar.gz
gentoo-4d260fb7efbf00a995bae2fe09748625c72f50cd.tar.bz2
gentoo-4d260fb7efbf00a995bae2fe09748625c72f50cd.zip
dev-python/dulwich-0.20.6: version bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.20.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 401b4853b78c..7f0c4dc3a6df 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,2 +1,3 @@
DIST dulwich-0.19.15.tar.gz 369491 BLAKE2B ffaabbd68ee228e771b8a56c9a5b70498e49a4547f3f0ff87225ca4ee0a222fca5cd75a36293fb0d111615f4fe9550acd2825732a178f67d9f6b538abf9fc37f SHA512 ae56cf4748ea5f9d275f2d1456bf9fce77859ad2eeba6b7d8f34283e212404ba385f377f4fb86b88dc40982649ec8cfb12ea407dd25ada7cb2b0e862568ac7da
DIST dulwich-0.20.5.tar.gz 384166 BLAKE2B f11ef1467a7f850666a850c42871b2bb798cdad54b4ad5a7d6fef8171cb5378982537574f9d2c783e2c9e7357624eec4c617c0b014d789d9f40f5bdfd56d8b39 SHA512 88c546fdc6cb4fbde1ebab5160e1f226259d85c934bee456c8a93b14f4c292550e685696fd25c27635f3342f82b0c67572059fb90e3e9b339aa0d11b9e010c25
+DIST dulwich-0.20.6.tar.gz 388660 BLAKE2B 1a193d03e0f21a9fdd125617823742b87e9bea74c73734da10eb79f1ecbec0263cb90224f78413c724db8998f4d06ff6c448e7a6d50ce760ba1545f3321b95d8 SHA512 2f11ce9a1c716fb4242f1f93fce92f756bd93ed8f0951fc2e6b3fb18b0a495b0f372966149fca587efcafc0eaf00e9fbfcfd957442a96cc2004eb66cb7f0773e
diff --git a/dev-python/dulwich/dulwich-0.20.6.ebuild b/dev-python/dulwich/dulwich-0.20.6.ebuild
new file mode 100644
index 000000000000..28c16b903611
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.20.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.org/project/dulwich/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ !hppa? ( !ia64? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ ) )
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-fastimport[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
+ GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}