summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-01-15 12:40:33 -0500
committerMike Gilbert <floppym@gentoo.org>2017-01-15 12:41:21 -0500
commit4d2997add72b9853e0da52efe8a7ca78ef10e8c4 (patch)
treef74a1499b88d77aaccfcdd5130b14ec95369fc8c /dev-python
parentapp-misc/elasticsearch: add missing die (diff)
downloadgentoo-4d2997add72b9853e0da52efe8a7ca78ef10e8c4.tar.gz
gentoo-4d2997add72b9853e0da52efe8a7ca78ef10e8c4.tar.bz2
gentoo-4d2997add72b9853e0da52efe8a7ca78ef10e8c4.zip
dev-python/python-djvulibre: bump to 0.8
Bug: https://bugs.gentoo.org/601518 Package-Manager: Portage-2.3.3_p32, Repoman-2.3.1_p25
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-djvulibre/Manifest1
-rw-r--r--dev-python/python-djvulibre/python-djvulibre-0.8.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-djvulibre/Manifest b/dev-python/python-djvulibre/Manifest
index 6ad85fb91c3f..d0c6f778eff6 100644
--- a/dev-python/python-djvulibre/Manifest
+++ b/dev-python/python-djvulibre/Manifest
@@ -1 +1,2 @@
DIST python-djvulibre-0.3.9.tar.gz 120663 SHA256 ca11e57ae14161788ba8ee48063136f3fa12aad887035a36c3b2bfb8346c1a44 SHA512 30c3ce2dc09d3e2d1d1c3608a76a4b4ea61d05dbc69a41476cfc3b0e99d68626b4dfbbad0acfdb074fe6ee6c36ad4a4e382a545d3dafc2f12d149fa96e034595 WHIRLPOOL ca675f63bd5455e40e2cac820dcb172043a0dc317830cb8264a4d4ebb6d2f8afa1309e7ab37197d4f9067c8335c3e41e14bed10f33fb11c54cbb0ad0d8a94c03
+DIST python-djvulibre-0.8.tar.gz 85436 SHA256 9d6bf3143fa540e8ce330949c9edff7847ad7cd715f7c02e2991212873a5f31b SHA512 c817fc518f398bf16664a5f5dc80e8bd086015c13f82c5265548e5ca5d90f293cb2132961ba8a73cb184bc7883bb5868d2d49ecd950d045d0729f876703e710c WHIRLPOOL c1b23f141ab31eb427aa7b373b55b9886ab2f1189d35837741503e442d7ce80e70550ecfba091052cf5d126b46de8ccf5632205acb8d229993abc75ebdd3c725
diff --git a/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild b/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
new file mode 100644
index 000000000000..366d9f73f01a
--- /dev/null
+++ b/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of Python bindings for the DjVuLibre library"
+HOMEPAGE="http://jwilk.net/software/python-djvulibre"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/djvu"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ ln -s "${S}/tests" "${BUILD_DIR}/tests" || die
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die
+}