summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 21:34:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 21:48:56 +0100
commit4d6e505c129e7512ac669b666b0a8edc65a24811 (patch)
tree872fc04d55ba25feb19ef92cb9a7cee81a50ca12 /dev-python
parentpackage.mask: Last rite sys-fs/ctmg (diff)
downloadgentoo-4d6e505c129e7512ac669b666b0a8edc65a24811.tar.gz
gentoo-4d6e505c129e7512ac669b666b0a8edc65a24811.tar.bz2
gentoo-4d6e505c129e7512ac669b666b0a8edc65a24811.zip
dev-python/proto-plus: Bump to 1.19.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.19.7.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index a51ca87dab6c..15c0caf13613 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1 +1,2 @@
DIST proto-plus-1.19.2.gh.tar.gz 61183 BLAKE2B 8c1c0a70ae573fc8c64004e4bd923f403bf82dbb3f9aef19239770fcd316e513ba11e6e47c56bda65c88e476072f0d90af02c83eb0fe8a4045cf3ceeccca3fc7 SHA512 c3cfb1b6aabeb4eab7f6c2c16551c1f9fbf29dc3199b496bc4b47b4b80cbe4684e5c97abe26fa4c1afd03c844a2e8f006f16c24932d2a7cf8190452943c2fad0
+DIST proto-plus-1.19.7.gh.tar.gz 64614 BLAKE2B 918bb04a084cff8a2188a68c31f08aebd25443fd399d69ba9734d002f773df2769904e4aa551cd1d93586ee4710f2b7160e6a8eb4160fe1bb846be18155a7b29 SHA512 118187a852a998deba3b5d7e700cd084eab966b549c7dba6150f318e9602f950a9533e27d775f9f0bca2fedaed6375b592bae42c55cf5aee8b52708fcc4691c8
diff --git a/dev-python/proto-plus/proto-plus-1.19.7.ebuild b/dev-python/proto-plus/proto-plus-1.19.7.ebuild
new file mode 100644
index 000000000000..762787eae60d
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.19.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="https://pypi.org/project/proto-plus/ https://github.com/googleapis/proto-plus-python"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme