summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 15:09:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 15:41:01 +0200
commit4fd47b56e4178508d3eab68a6a401537c8f437ab (patch)
treeed1e0af36e6ff28f61a49576c1eb19846b2961d8 /dev-python
parentdev-python/contextlib2: Enable py3.10 (diff)
downloadgentoo-4fd47b56e4178508d3eab68a6a401537c8f437ab.tar.gz
gentoo-4fd47b56e4178508d3eab68a6a401537c8f437ab.tar.bz2
gentoo-4fd47b56e4178508d3eab68a6a401537c8f437ab.zip
dev-python/pytest-shutil: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild
index 7a36fd6f0175..cee304ff4f5f 100644
--- a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild
+++ b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -14,8 +14,6 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
@@ -36,15 +34,11 @@ BDEPEND="
dev-python/setuptools-git[${PYTHON_USEDEP}]
"
+distutils_enable_tests --install setup.py
+
python_prepare_all() {
# keeps trying to install this in tests
sed -i 's:path.py::' setup.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- distutils_install_for_testing
-
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}