summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-18 09:44:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-18 10:48:28 +0200
commit51ebc9362e5e9e3a8c5647a43d1a925c2a364e4c (patch)
tree58ca04ebaed02992391e41dfb7db5de9a0e51a4f /dev-python
parentdev-python/snowballstemmer: Enable python3.10 (diff)
downloadgentoo-51ebc9362e5e9e3a8c5647a43d1a925c2a364e4c.tar.gz
gentoo-51ebc9362e5e9e3a8c5647a43d1a925c2a364e4c.tar.bz2
gentoo-51ebc9362e5e9e3a8c5647a43d1a925c2a364e4c.zip
dev-python/pydocstyle: Bump to 6.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydocstyle/Manifest1
-rw-r--r--dev-python/pydocstyle/files/pydocstyle-6.1.1-disarm-pip-install.patch31
-rw-r--r--dev-python/pydocstyle/pydocstyle-6.1.1.ebuild27
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
index 809dedd258dd..4192487cbf2c 100644
--- a/dev-python/pydocstyle/Manifest
+++ b/dev-python/pydocstyle/Manifest
@@ -1 +1,2 @@
DIST pydocstyle-6.0.0.tar.gz 72143 BLAKE2B 1036a5eab38a38bda0f98371f7e4094248cf5057a9afd8743a478f153a5f06feab6b3e7d6be031615b5e88c388786f59a0619f774f492e40a722f39973051d5b SHA512 609a10307aa24513f476ef639771fc095fe7a65ffd8d530fad02886369c62969c69a5134fd0ec79a1e07d1b6cb8f920c3478db546c26aefb0e45771777c02a0b
+DIST pydocstyle-6.1.1.tar.gz 73982 BLAKE2B 6a896221fdcd257f0475472e1cf87ef892d8292a4c0faf661595adb17e2d18f4a8277cda498197309d34597c448203856c272256277a7e35fba20e2e5ba47f2b SHA512 ce4932a6601c80d05a46600f5af7df54798025a5f3dc41ab8cf1bc0d63e7f78b70cccb17dc99ddab25eda9abd639f91468fca1b1ceb4539708350212e481a156
diff --git a/dev-python/pydocstyle/files/pydocstyle-6.1.1-disarm-pip-install.patch b/dev-python/pydocstyle/files/pydocstyle-6.1.1-disarm-pip-install.patch
new file mode 100644
index 000000000000..b0467a136435
--- /dev/null
+++ b/dev-python/pydocstyle/files/pydocstyle-6.1.1-disarm-pip-install.patch
@@ -0,0 +1,31 @@
+From 46947c9dca95caeb7b1f4348994d1aa2b8db93ec Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 18 May 2021 10:02:16 +0200
+Subject: [PATCH] Disarm install_package fixture
+
+---
+ src/tests/test_integration.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/src/tests/test_integration.py b/src/tests/test_integration.py
+index eb4994f..4242476 100644
+--- a/src/tests/test_integration.py
++++ b/src/tests/test_integration.py
+@@ -128,14 +128,7 @@ def install_package(request):
+ This is so we can run the integration tests on the installed console
+ script.
+ """
+- cwd = os.path.join(os.path.dirname(__file__), '..', '..')
+- subprocess.check_call(
+- [sys.executable, "-m", "pip", "install", "-e", "."], cwd=cwd
+- )
+ yield
+- subprocess.check_call(
+- [sys.executable, "-m", "pip", "uninstall", "-y", "pydocstyle"], cwd=cwd
+- )
+
+
+ @pytest.yield_fixture(scope="function", params=['ini', 'toml'])
+--
+2.31.1
+
diff --git a/dev-python/pydocstyle/pydocstyle-6.1.1.ebuild b/dev-python/pydocstyle/pydocstyle-6.1.1.ebuild
new file mode 100644
index 000000000000..f97c88a48af6
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-6.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/toml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests --install pytest
+# Requires network to lookup github issues
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+PATCHES=(
+ "${FILESDIR}"/pydocstyle-6.1.1-disarm-pip-install.patch
+)