summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-24 08:45:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-24 12:21:45 +0200
commit55156dd99029036aa5bf0f4e3137da4a05bbbc74 (patch)
tree751b9f2ec4d4151d257b4bf7d31b3eaf80f4026d /dev-python
parentdev-lang/yap: support Python 3.9 (diff)
downloadgentoo-55156dd99029036aa5bf0f4e3137da4a05bbbc74.tar.gz
gentoo-55156dd99029036aa5bf0f4e3137da4a05bbbc74.tar.bz2
gentoo-55156dd99029036aa5bf0f4e3137da4a05bbbc74.zip
dev-python/indexed_gzip: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/indexed_gzip/Manifest1
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.6.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/indexed_gzip/Manifest b/dev-python/indexed_gzip/Manifest
index 1d1b3858635d..f3c2c97d75e1 100644
--- a/dev-python/indexed_gzip/Manifest
+++ b/dev-python/indexed_gzip/Manifest
@@ -1 +1,2 @@
DIST indexed_gzip-0.8.10.tar.gz 79133 BLAKE2B ebb5bc69d92b627b0546c8570ea533a7d6541cffbda6ddbf38d2712e5d7b13f5684a4d962b457cb0beaf8f6d9d6c5bd810c31af18396d7ce2a7d3f9ce0a039d6 SHA512 cd57a0442e95a4760d710227a5d9f69841bef851427c536e5cfde7c9f962c9d403e0b38341ba2e07c5cde668e0f26ff7848d154f6243a2cee1cf6c327a7f4e1e
+DIST indexed_gzip-1.6.0.tar.gz 99260 BLAKE2B 15fff478a275baf59f152040455502f57762889959c4d2989e44b626dad25d381ff73029107c4495b477397ff5dc0763d1934f23bcc85a6296a0eec85a36b421 SHA512 0e01da5e8c527202c1f18148bad2a8ebec9ca0bc1bc49ce4804c6a32397797525cc7bfdfc254139c3c1b037d3f65171c010453ff3fae6e6256304ddf486bc58d
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.6.0.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.6.0.ebuild
new file mode 100644
index 000000000000..074e482ab133
--- /dev/null
+++ b/dev-python/indexed_gzip/indexed_gzip-1.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
+SRC_URI="https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=indexed_gzip::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local ignore=(
+ # requires nibabel
+ indexed_gzip/tests/test_nibabel_integration.py
+ )
+
+ cd "${BUILD_DIR}"/lib || die
+ epytest ${ignore[@]/#/--ignore }
+}