summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-23 14:19:32 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-23 14:20:11 -0400
commit55866ca8962513c92097700351a18c8c0167828d (patch)
treee06281f265f9f3aa4a84e71fbb7804d81816541c /dev-python
parentdev-python/tox: stabilize 2.7.0 for amd64/x86 (diff)
downloadgentoo-55866ca8962513c92097700351a18c8c0167828d.tar.gz
gentoo-55866ca8962513c92097700351a18c8c0167828d.tar.bz2
gentoo-55866ca8962513c92097700351a18c8c0167828d.zip
dev-python/tox: remove old
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-2.4.1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 7e0b7a31a91b..04cf8728b365 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,2 @@
-DIST tox-2.4.1.tar.gz 113677 SHA256 6673571a3c4b1561b564e2b1cce55bddfb4f3efdb387ba4eb0a3688bbe2496db SHA512 f636b08a9f386ad20058581ca03cae0a259fe3432d3d4bd9a5117c30cb2f2c2d35d7fd499057654cd55d86c172456101f82b320d120f67afd8669a74fa63b860 WHIRLPOOL 7386f0b30e50dd8d89e05871491347849ee18b11cc89b0871cbe2719b2a75b140afa65c5d4b5e7c4266f33f89c7a36e24aa52036ae8845d5ad70279d417abb2d
DIST tox-2.7.0.tar.gz 120139 SHA256 9c3bdc06fe411d24015e8bbbab9d03dc5243a970154496aac13f9283682435f9 SHA512 96088a9f77e8b994d920a8c9907a0fa50d5e0fe918e5a67673d4c30810642be2872283810d1d8b5ae9cc311605236b64343248485c4d4067b54c7b6d9f31a4b4 WHIRLPOOL ed77717cfead6e98ff31fb773b31bcf55bb8c4892c281aae68d10459f4ffe0c386d5adc7e1dcaacfffe2a17e005231d1dc51f3ddb3900cb09547eba6ed444628
DIST tox-2.8.1.tar.gz 125777 SHA256 de0abf4e8992c056bc22afff9d969e0cae2e39452a9650bdbcbe7154793537b7 SHA512 a230f7bc48f476825ca1a879e669288b311f266f1695bac4eecfcd44076731e5581a425e36555a0db54f8a0683af31abd77ab862aa40525387e6e436ba351c37 WHIRLPOOL 18f146f0b09e64fbc656fff9a8e098422cd8abd38ea6a09e29489c9cd3dfb3e6d4540922e5ea569d0dc3323c63f8f1c132fe75125f2e7ebb6d409ee086eee6e6
diff --git a/dev-python/tox/tox-2.4.1.ebuild b/dev-python/tox/tox-2.4.1.ebuild
deleted file mode 100644
index 117e7fe9735a..000000000000
--- a/dev-python/tox/tox-2.4.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="virtualenv-based automation of test activities"
-HOMEPAGE="https://tox.testrun.org https://pypi.python.org/pypi/tox"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-1.11.2[${PYTHON_USEDEP}]
- dev-python/pluggy[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- >=dev-python/py-1.4.17[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Take out failing tests known to pass when run manually
- # # Run from ebuild interferes in subtle & mysterious ways, inducing these erroroneous fails
- sed \
- -e 's:test_package_install_fails:_&:' \
- -e 's:test_different_config_cwd:_&:' \
- -e 's:test_develop:_&:' \
- -e 's:test_usedevelop:_&:' \
- -e 's:test_usedevelop_mixed:_&:' \
- -e 's:test__test_usedevelop:_&:' \
- -e 's:test_env_VIRTUALENV_PYTHON:_&:' \
- -i tests/test_z_cmdline.py || die
-
- if use doc; then
- local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
- local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
- local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
- local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
- sed \
- -e "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" \
- -i doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test -v -v tests || die "Testsuite failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( "${S}"/doc/_build/html/. )
- distutils-r1_python_install_all
-}