summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-07-02 14:42:11 +0200
committerDavid Seifert <soap@gentoo.org>2016-07-02 15:09:39 +0200
commit56d66d8396ed2823ca93669888dca87f04a6cc0b (patch)
treeb2acdee520ec4be29adb735366125e2bfe50746d /dev-python
parentdev-python/py-smbpasswd: remove old and deprecated (diff)
downloadgentoo-56d66d8396ed2823ca93669888dca87f04a6cc0b.tar.gz
gentoo-56d66d8396ed2823ca93669888dca87f04a6cc0b.tar.bz2
gentoo-56d66d8396ed2823ca93669888dca87f04a6cc0b.zip
dev-python/pyamazon: Modernize to python-r1 suite
* EAPI=6 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/1814 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyamazon/pyamazon-0.65-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyamazon/pyamazon-0.65-r1.ebuild b/dev-python/pyamazon/pyamazon-0.65-r1.ebuild
new file mode 100644
index 000000000000..81a15b158761
--- /dev/null
+++ b/dev-python/pyamazon/pyamazon-0.65-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="A Python wrapper for the Amazon web API"
+HOMEPAGE="http://www.josephson.org/projects/pyamazon"
+SRC_URI="http://www.josephson.org/projects/${PN}/files/${P}.zip"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ edos2unix amazon.py
+}
+
+src_install() {
+ python_domodule amazon.py
+}