summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-21 03:58:07 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-21 03:58:52 -0400
commit58f47d605662bb229616a8f7e27ef359c4c06f56 (patch)
tree1f70850a445a9db8e449c9f519accd49336d0396 /dev-python
parentdev-python/pythonmagick: version bump to 0.9.14 (diff)
downloadgentoo-58f47d605662bb229616a8f7e27ef359c4c06f56.tar.gz
gentoo-58f47d605662bb229616a8f7e27ef359c4c06f56.tar.bz2
gentoo-58f47d605662bb229616a8f7e27ef359c4c06f56.zip
dev-python/xcffib: version bump to 0.4.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/files/xcffib-0.4.2-test-imports.patch35
-rw-r--r--dev-python/xcffib/xcffib-0.4.2.ebuild38
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index 7ded8d982e87..11994c306f17 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1,2 +1,3 @@
DIST xcffib-0.3.4.tar.gz 65481 SHA256 9c54f835351a1622495322f314ee58ca5cb498fe8a2123a3905a25c1fd66850b SHA512 7c70dc6ae37531e6e9649a9055e4740872fc071620825d647525a236cad95e24e2c5f950e5f916b3742588a3c79363fe56431aba0488d939930398022c832be2 WHIRLPOOL 9b99ae6959bea33df013f21f897edba89d0b66b775ed1c019f5c2a61a23293fb26a0bf3311aa225a05e862bac95ac3d4bcad50023a56dde83a2b12b968b4a987
DIST xcffib-0.4.0.tar.gz 74715 SHA256 94a3d3d48289a7e9e0687b1f9a5f69de6e6449ac98df0f79773b286a72f79f8a SHA512 ac144ffdfb559ae2ee8d4a23c937989ca4e28f913b2d27f1240725c8398ede1a7a010a0d861998151923d235d5e04799d8df8496c9ec8005a2286825dcd59bd7 WHIRLPOOL f67aba9f217a2aa408945f4f2703853385ce8170d069660f9433410c13ca41bbf9ba5fd9729509192996d34d934626a1c0f91e08a64e44b4aef43fb4e88b5c74
+DIST xcffib-0.4.2.tar.gz 80441 SHA256 7f4210f1ee51bb6f87e747438699fcf449ece2cb354d106be474997e479cacb8 SHA512 df9d5e9500cb3ea9765d4f887bdc018a99c285eff5aa4c922cb59da89bd04640b6ba9d7a3b83cfa999bdc3749f438b1a4b336117e2885fe2e27d346439839a7e WHIRLPOOL 4670e8a2179ccf149bb91e415c5ed81a68268f898fe29a4c0918c27d1a2647736587ab5aa7ba268608defe6d4c0655a94120dbacaa3c0970faed87379412a609
diff --git a/dev-python/xcffib/files/xcffib-0.4.2-test-imports.patch b/dev-python/xcffib/files/xcffib-0.4.2-test-imports.patch
new file mode 100644
index 000000000000..da33bf3934cb
--- /dev/null
+++ b/dev-python/xcffib/files/xcffib-0.4.2-test-imports.patch
@@ -0,0 +1,35 @@
+Relative imports don't work because the test dir isn't a proper python module.
+
+--- xcffib-0.4.2/test/test_connection.py
++++ xcffib-0.4.2/test/test_connection.py
+@@ -20,7 +20,7 @@
+
+ from xcffib import ffi
+ from xcffib.testing import XvfbTest
+-from .testing import XcffibTest
++from testing import XcffibTest
+
+ from nose.tools import raises
+ from nose import SkipTest
+--- xcffib-0.4.2/test/test_fakeinput.py
++++ xcffib-0.4.2/test/test_fakeinput.py
+@@ -2,7 +2,7 @@
+ import xcffib.xproto
+ import xcffib.xtest
+
+-from .testing import XcffibTest
++from testing import XcffibTest
+
+ class TestConnection(XcffibTest):
+ def test_fakeinput(self):
+--- xcffib-0.4.2/test/test_python_code.py
++++ xcffib-0.4.2/test/test_python_code.py
+@@ -18,7 +18,7 @@
+ import struct
+ from xcffib.xproto import EventMask
+
+-from .testing import XcffibTest
++from testing import XcffibTest
+
+ class TestPythonCode(XcffibTest):
+
diff --git a/dev-python/xcffib/xcffib-0.4.2.ebuild b/dev-python/xcffib/xcffib-0.4.2.ebuild
new file mode 100644
index 000000000000..3db55a82e271
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ dev-python/six[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-apps/xeyes
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-test-imports.patch )
+
+python_test() {
+ nosetests -d -v || die
+}