summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2019-11-20 13:00:19 +0100
committerAgostino Sarubbo <ago@gentoo.org>2019-11-20 13:00:19 +0100
commit599638daf8025e7fa1db07fe5277f80856081b66 (patch)
tree2f908a10f1ed4fcc1ceca5e0c18ab1103516ed5b /dev-python
parentapp-emacs/d-mode: Add test restriction. (diff)
downloadgentoo-599638daf8025e7fa1db07fe5277f80856081b66.tar.gz
gentoo-599638daf8025e7fa1db07fe5277f80856081b66.tar.bz2
gentoo-599638daf8025e7fa1db07fe5277f80856081b66.zip
dev-python/hcloud-python: version bump to 1.6.2
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.6.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index e6d4da4daec5..32b4c2880af1 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,2 +1,3 @@
DIST hcloud-python-1.2.1.tar.gz 63592 BLAKE2B 9a6d2dae97ff405ebd9b92bc833c9d953c13840e68be4eb43fed375a60e55cf4bf9b4b742b26fb03401f631b7f7127815961861cb673adf4839c829141c8ed00 SHA512 cb70d190350457fc3c6e474bc6c943070102762595dac2f386041956f64255f390a928a2f2411be861645cd65b015ab9e0c931b36aeed0076b06d9f67ac72d1c
DIST hcloud-python-1.6.1.tar.gz 71866 BLAKE2B 0a1d37d4dc8be4e28595385ec7622ec65367c40f9cdd455e03827a5ee2983f43026b1dbb7e9bd20d241ed9a4748015d33bdcb53b15ce148c401984960e158716 SHA512 0b2ecaa311b4dac44b3122a45a38f76f8377bc189b1550f21327ea3f56fefad624ea6809c4abd6bbaf5c8fc23dfa5e6edd352dcbbcfae6c87af897ff376ce2cf
+DIST hcloud-python-1.6.2.tar.gz 71887 BLAKE2B 2c423b0b83cc8c7bd5f0d4ef7db59516f125ff975e8cb82f38b340a0f448c20dd374a1edc7a486d18af3d438722b77f32f4ab6191966e3ada13f437f2d8a29a4 SHA512 ae2da263a038add593c7e302057d6e5e34258f180bddf67fc23edcc8c287c67d91aa190efeb1190af2596017b8964f4623d9cc03c4f1788c71c7d251f2a5422d
diff --git a/dev-python/hcloud-python/hcloud-python-1.6.2.ebuild b/dev-python/hcloud-python/hcloud-python-1.6.2.ebuild
new file mode 100644
index 000000000000..d6166ae001a5
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.6.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+COMMON_DEPEND=">=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-2.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+ <dev-python/requests-2.23[${PYTHON_USEDEP}]"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
+ <dev-python/future-0.19[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}