summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-11-05 00:09:02 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-14 20:23:23 +0100
commit5ca590df4636e72c4c889fbcb7a67054c966d6f7 (patch)
tree72e2470a4639094008398a147235a02c6159f752 /dev-python
parentapp-misc/jira-cli: Initial version (diff)
downloadgentoo-5ca590df4636e72c4c889fbcb7a67054c966d6f7.tar.gz
gentoo-5ca590df4636e72c4c889fbcb7a67054c966d6f7.tar.bz2
gentoo-5ca590df4636e72c4c889fbcb7a67054c966d6f7.zip
dev-python/cryptography: bump 1.5.3-r1, eapi update, fix test on first install
On first install the test would fail because it uses introspection but the egg-info was not available. On second install it would work because introspection would (wrongly) inspect the system installed package. Added distutils_install_for_testing to have a complete install available for testing. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=595272 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2746 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/Manifest1
-rw-r--r--dev-python/cryptography/cryptography-1.5.2.ebuild49
-rw-r--r--dev-python/cryptography/cryptography-1.5.3-r1.ebuild (renamed from dev-python/cryptography/cryptography-1.5.3.ebuild)2
3 files changed, 2 insertions, 50 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index 44776bad24e3..c4161046c4f6 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -1,5 +1,4 @@
DIST cryptography-1.1.2.tar.gz 349022 SHA256 7f51459f84d670444275e615839f4542c93547a12e938a0a4906dafe5f7de153 SHA512 566e346a76cfd6b1c6afbf64d1fe496770b1ad5f471c42877ad6931a441ab77408815ae066ba3f0450766c86ae9dd10d7a5966321f93a979a4e1ab9e1201371b WHIRLPOOL 9a552e65047c45e19e313e0530031fa282aec51577bcc64f9346f37ac99663db052f7ccc1798532103edffa6e778f9585e937a862a475f6d7bd9140d06bbcf57
DIST cryptography-1.3.1.tar.gz 383852 SHA256 b4b36175e0f95ddc88435c26dbe3397edce48e2ff5fe41d504cdb3beddcd53e2 SHA512 8b833619d0aec5e6630c8e069e886f6b708b0b3a4f4ca4e37797a24c69be4cacf162f20c068deaecc3222ee0323583582d384e49fa3dbaeaeefc0d7d8c92918a WHIRLPOOL f9e7c75e910699afdf4adc4fb7257135b97c357c967bbca95f332e1f2ed262716ebba6a648427f86a524e75f6ac46aea7f891fe42100c9d7cf8ffcc317fb7905
DIST cryptography-1.3.4.tar.gz 384109 SHA256 423ff890c01be7c70dbfeaa967eeef5146f1a43a5f810ffdc07b178e48a105a9 SHA512 abbc027433658702d2331282c9f63d99ea2eb42f5cdfe066b2b0ae6d9b86a35e23891716bb2e9e2ca707aa0d38fb69cba22ec5d95d2b9073047444fdae7a9224 WHIRLPOOL 5bd007cfe304620a7237b0f63fbe87ab22bd1cc252941f4815398382122b1c56c5a22e2dc35ce86aba2c2b2d9403de3313bafde23a3695bd26e4eb0f23c9dea9
-DIST cryptography-1.5.2.tar.gz 400673 SHA256 eb8875736734e8e870b09be43b17f40472dc189b1c422a952fa8580768204832 SHA512 7f50edfe7a7270a7acef52b7c55a32eca1845c5e410f078c42690a2e18fce001ed5dfd268fb18a2219011eff073914f1e2271d8e957c58b5200615a815a4b4c0 WHIRLPOOL 2625cbe43d7b0ce41cfcb4a1a9f8127b5933abe86bf30151cfd0b2dc8de0aeea01dc19649528474989ec0121c8b6e6e2e9c8fe72a60e1f2eb10536d7042ea272
DIST cryptography-1.5.3.tar.gz 400889 SHA256 cf82ddac919b587f5e44247579b433224cc2e03332d2ea4d89aa70d7e6b64ae5 SHA512 0985d22a77821c2b3e78887e17d4046873bf19ff167561e228cfea4cabc02e6ac894b2c72638b7c3414ae5aeb51d1b8bbd67e255ef3dc2043cfcc8ee67bb412f WHIRLPOOL fd35a44f0415ef55a9b5f1e8d53c08824972420a53e402ecbfa90f39ff04fae0be534cd15a6d96f702cb58e1eccf4c6c251d0f39525acd8b703a1f9f752348c0
diff --git a/dev-python/cryptography/cryptography-1.5.2.ebuild b/dev-python/cryptography/cryptography-1.5.2.ebuild
deleted file mode 100644
index 25278c1f6427..000000000000
--- a/dev-python/cryptography/cryptography-1.5.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Library providing cryptographic recipes and primitives"
-HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 BSD )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="libressl test"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl )
- $(python_gen_cond_dep '>=dev-python/cffi-1.4.1:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
- >=dev-python/idna-2.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
- virtual/python-ipaddress[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- test? (
- ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-
-python_test() {
- py.test -v -v -x || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cryptography/cryptography-1.5.3.ebuild b/dev-python/cryptography/cryptography-1.5.3-r1.ebuild
index 0098515d49d6..5fb681b19472 100644
--- a/dev-python/cryptography/cryptography-1.5.3.ebuild
+++ b/dev-python/cryptography/cryptography-1.5.3-r1.ebuild
@@ -45,5 +45,7 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
python_test() {
+ distutils_install_for_testing
+
py.test -v -v -x || die "Tests fail with ${EPYTHON}"
}