summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-13 10:30:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-13 11:02:59 +0200
commit6025336afa774618665d597e273221ba89cd5c31 (patch)
treeb479641a4bf7d11f6784bbe935f2f089cb46d1a1 /dev-python
parentdev-python/appdirs: Add missing ebuild for 1.4.4 (diff)
downloadgentoo-6025336afa774618665d597e273221ba89cd5c31.tar.gz
gentoo-6025336afa774618665d597e273221ba89cd5c31.tar.bz2
gentoo-6025336afa774618665d597e273221ba89cd5c31.zip
dev-python/pytest: Fix tests on initial install
Closes: https://bugs.gentoo.org/715318 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest/pytest-4.6.10.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/pytest/pytest-4.6.10.ebuild b/dev-python/pytest/pytest-4.6.10.ebuild
index eb17b00753d9..ebd5ee838156 100644
--- a/dev-python/pytest/pytest-4.6.10.ebuild
+++ b/dev-python/pytest/pytest-4.6.10.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit distutils-r1
@@ -41,7 +42,6 @@ RDEPEND="
# flake cause a number of tests to fail
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/argcomplete[${PYTHON_USEDEP}]
@@ -72,6 +72,8 @@ python_prepare_all() {
}
python_test() {
+ distutils_install_for_testing
+
# In v4.1.1, pytest started being picky about its own verbosity options.
# running pytest on itself with -vv made 3 tests fail. This is why we don't
# have it below.