summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-26 14:06:27 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-26 14:06:38 -0400
commit62e4c40e3cca9729f60b5a2641a8587445550065 (patch)
tree92c4a54e934a40eed061f179ccec2ba58222ed26 /dev-python
parentnet-libs/nghttp2: version bump to 1.9.0 (diff)
downloadgentoo-62e4c40e3cca9729f60b5a2641a8587445550065.tar.gz
gentoo-62e4c40e3cca9729f60b5a2641a8587445550065.tar.bz2
gentoo-62e4c40e3cca9729f60b5a2641a8587445550065.zip
dev-python/jsonrpclib: version bump to 0.1.7 #577938
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild27
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild2
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild
new file mode 100644
index 000000000000..918b50d36e1b
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.1.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/joshmarshall/jsonrpclib.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/joshmarshall/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
index 101ea1209ee4..918b50d36e1b 100644
--- a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/joshmarshall/jsonrpclib.git"
inherit git-2
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ SRC_URI="https://github.com/joshmarshall/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~mips ~x86"
fi