summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-08 21:16:18 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-08 21:16:18 +0200
commit6334fb0c2c6ed9dc4efb5e82169c4f2a3407a78d (patch)
tree23ec7935bffd6012bf721ae2362ca65fd4d0af53 /dev-python
parentdev-python/pyml: Remove old (diff)
downloadgentoo-6334fb0c2c6ed9dc4efb5e82169c4f2a3407a78d.tar.gz
gentoo-6334fb0c2c6ed9dc4efb5e82169c4f2a3407a78d.tar.bz2
gentoo-6334fb0c2c6ed9dc4efb5e82169c4f2a3407a78d.zip
dev-python/workerpool: [QA] Call distutils-r1_python_install_all
* Also remove USE=examples, as it was completely broken. Closes: https://bugs.gentoo.org/682648 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/workerpool/workerpool-0.9.4.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/dev-python/workerpool/workerpool-0.9.4.ebuild b/dev-python/workerpool/workerpool-0.9.4.ebuild
index 84dc0f5b229b..05004de15b02 100644
--- a/dev-python/workerpool/workerpool-0.9.4.ebuild
+++ b/dev-python/workerpool/workerpool-0.9.4.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
@@ -13,20 +14,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test examples"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
nosetests -v test || die
}
-
-python_install_all() {
- if use examples; then
- docompress -x usr/share/doc/${P}/samples
- insinto usr/share/doc/${P}/
- doins -r samples
- fi
-}