summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-25 17:05:24 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-25 23:49:12 +0200
commit63581c519419c7ef888b7e51f557af0afa99a922 (patch)
tree09703516960dcafc6a34760a2003b2751dfcd334 /dev-python
parentdev-python/pypy: Bump 9999 to EAPI 6 (diff)
downloadgentoo-63581c519419c7ef888b7e51f557af0afa99a922.tar.gz
gentoo-63581c519419c7ef888b7e51f557af0afa99a922.tar.bz2
gentoo-63581c519419c7ef888b7e51f557af0afa99a922.zip
dev-python/pypy: Disarm implicit -flto (in 9999)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy/files/5.7.1-kill-flto.patch27
-rw-r--r--dev-python/pypy/pypy-9999.ebuild2
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pypy/files/5.7.1-kill-flto.patch b/dev-python/pypy/files/5.7.1-kill-flto.patch
new file mode 100644
index 000000000000..92395bdb6cab
--- /dev/null
+++ b/dev-python/pypy/files/5.7.1-kill-flto.patch
@@ -0,0 +1,27 @@
+From 261f9280d9736965a8626c2d6a6fadd4254b2b89 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 25 Apr 2017 17:03:46 +0200
+Subject: [PATCH] Kill -flto
+
+---
+ rpython/translator/platform/posix.py | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/rpython/translator/platform/posix.py b/rpython/translator/platform/posix.py
+index a8d4768..20a2934 100644
+--- a/rpython/translator/platform/posix.py
++++ b/rpython/translator/platform/posix.py
+@@ -130,10 +130,6 @@ class BasePosix(Platform):
+ else:
+ cflags = tuple(self.cflags) + tuple(self.standalone_only)
+
+- # xxx check which compilers accept this option or not
+- if not config or config.translation.gcrootfinder != 'asmgcc':
+- cflags = ('-flto',) + cflags
+-
+ m = GnuMakefile(path)
+ m.exe_name = path.join(exe_name.basename)
+ m.eci = eci
+--
+2.12.2
+
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index c4d67f9bbc16..4e672b8cf6b2 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -96,6 +96,8 @@ src_prepare() {
eapply "${FILESDIR}/4.0.0-gentoo-path.patch"
eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
eapply "${FILESDIR}"/2.5.0-shared-lib.patch # 517002
+ # disarm implicit -flto
+ eapply "${FILESDIR}"/5.7.1-kill-flto.patch
sed -e "s^@EPREFIX@^${EPREFIX}^" \
-e "s^@libdir@^$(get_libdir)^" \