summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 20:07:11 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 20:18:24 +0200
commit6502d44346a2ed4c29c6b64c9b634e67e5025802 (patch)
treeca8ee525f4743221db4d040e10e2d9cbb6bb2f59 /dev-python
parentdev-python/xlsxwriter: Bump (diff)
downloadgentoo-6502d44346a2ed4c29c6b64c9b634e67e5025802.tar.gz
gentoo-6502d44346a2ed4c29c6b64c9b634e67e5025802.tar.bz2
gentoo-6502d44346a2ed4c29c6b64c9b634e67e5025802.zip
dev-python/cssselect: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cssselect/Manifest1
-rw-r--r--dev-python/cssselect/cssselect-0.9.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/cssselect/Manifest b/dev-python/cssselect/Manifest
index b12618b6b3a1..5f8a244ff039 100644
--- a/dev-python/cssselect/Manifest
+++ b/dev-python/cssselect/Manifest
@@ -1 +1,2 @@
DIST cssselect-0.9.1.tar.gz 32952 SHA256 0535a7e27014874b27ae3a4d33e8749e345bdfa62766195208b7996bf1100682 SHA512 c4cd2c8d6fbfa99b836554685dd59e1e794e1fab06fcf4419a226b0608a05d58be5af54e507003f2a233a22f03d59d3d63c0bf19b3314f15c95ab3ce5f4db6cc WHIRLPOOL 0fabe49d4f504069eb782ba98c93a34fa9433fd4d10a545f46f5aa1a5fb3a898580f4e17d744052590e18fe7a0f06feca0527d86ac243282e826caddfb410324
+DIST cssselect-0.9.2.tar.gz 33065 SHA256 713b5b99ef08022257b3409c7ae1b18b2c6536b3f155e6237c5cfba0f67ae6f5 SHA512 313965d3a0ad37b24d72d6faf861c04e7af7e4ff06f58450a23585c45bd9f247e565a4b7d594c008d40625601c2b8e76919801b3d77cfd62c7edc20cf366c1f9 WHIRLPOOL 90907b0cbc799d9e7f00ea366a24101fa4ff84786add028a035a355b4e8ce2073da82dfc4bc3a8e9a058341e117887e5ea1bac0e3b4befd8ac5df1bbbb21a2ca
diff --git a/dev-python/cssselect/cssselect-0.9.2.ebuild b/dev-python/cssselect/cssselect-0.9.2.ebuild
new file mode 100644
index 000000000000..ce7cfbc4f88a
--- /dev/null
+++ b/dev-python/cssselect/cssselect-0.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="parses CSS3 Selectors and translates them to XPath 1.0"
+HOMEPAGE="http://packages.python.org/cssselect/ https://pypi.python.org/pypi/cssselect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_prepare_all() {
+ # prevent non essential d'load of files in doc build
+ sed -e 's:intersphinx_:#&:' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc ; then
+ "${PYTHON}" setup.py build_sphinx || die
+ fi
+}
+
+python_test() {
+ "${PYTHON}" ${PN}/tests.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}