summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-04-25 13:49:46 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-25 13:49:46 +0200
commit6633ad94a0db0b02ae2451b6c71149d83df7b85d (patch)
treef7300a3a3b428a7646a702a8e1a4140989e1619d /dev-python
parentdev-ml/cairo-ocaml: Remove last-rited pkg (diff)
downloadgentoo-6633ad94a0db0b02ae2451b6c71149d83df7b85d.tar.gz
gentoo-6633ad94a0db0b02ae2451b6c71149d83df7b85d.tar.bz2
gentoo-6633ad94a0db0b02ae2451b6c71149d83df7b85d.zip
dev-python/elasticsearch-curator: Remove last-rited pkg
Closes: https://bugs.gentoo.org/714860 Closes: https://bugs.gentoo.org/775017 Closes: https://bugs.gentoo.org/775014 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/elasticsearch-curator/Manifest3
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1-r2.ebuild163
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1-r3.ebuild165
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-5.8.3.ebuild165
-rw-r--r--dev-python/elasticsearch-curator/metadata.xml9
5 files changed, 0 insertions, 505 deletions
diff --git a/dev-python/elasticsearch-curator/Manifest b/dev-python/elasticsearch-curator/Manifest
deleted file mode 100644
index 397f32db97d5..000000000000
--- a/dev-python/elasticsearch-curator/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST elasticsearch-7.3.2-linux-x86_64.tar.gz 285050383 BLAKE2B 730d8550f5887facae3075ce3b0bdb96b49350782fe7e687b8f4477bb363ce7c1595f2b1ece2b7d59d18539886b6e4806f56b0f5674bc417528232a92f1c00a8 SHA512 08e89347797ec6f008fb76cda17ec3e0dbc553fc992d07f4944fd99d17d5bc934849d9e534724d1541432c9844d3da57d875bc08a0c4cd95ba4251e2b03f833b
-DIST elasticsearch-curator-5.8.1.tar.gz 231233 BLAKE2B d2369c18be69cc5c8e17a6d7a72660bd7165c349cdb06c740c8db9dd2b583f181a09ba7d53ee0f4692cb6e31d373274f0610f2a654ba4a6da2d0ca0ff22c7c97 SHA512 500767967f423629f34d42ee088a9c007e193216c42f5590364ffcacc9e1efeba65dd4d333f806250e3b7fe0bea8b5501d1e6f3bf6fb0b8c46a46954e92c4a65
-DIST elasticsearch-curator-5.8.3.tar.gz 239107 BLAKE2B 6f924dd2e5d39f06741dbb0529f4ea8bb61a280ebe901682ffd95054cd1ad2b30ef5619d0d4c8237923a6ab3d9bd7531a7bc6ff674435d807f1f146a2ecb57e7 SHA512 243d37aa36a50711b57aeb1df61ed48f29e5097d9f7d5b515a5437dca2b4eb92ed92a4886db3213ef549192d9886c20ee10133856990e8c0ebaa16bb24a10592
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1-r2.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1-r2.ebuild
deleted file mode 100644
index a64c2354dba1..000000000000
--- a/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1-r2.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-MY_PN="curator"
-ES_VERSION="7.3.2"
-
-inherit distutils-r1
-
-DESCRIPTION="Tending time-series indices in Elasticsearch"
-HOMEPAGE="https://github.com/elastic/curator"
-SRC_URI="https://github.com/elastic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-${ES_VERSION}-linux-x86_64.tar.gz )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-# tests fail in chroot
-# https://github.com/elastic/elasticsearch/issues/12018
-RESTRICT="test"
-IUSE="doc test"
-
-# vulnerable pyyaml
-# https://github.com/elastic/curator/issues/1415
-RDEPEND="
- >=dev-python/elasticsearch-py-7.0.4[${PYTHON_USEDEP}]
- <dev-python/elasticsearch-py-8.0.0[${PYTHON_USEDEP}]
- >=dev-python/click-6.7[${PYTHON_USEDEP}]
- <dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/certifi-2019.9.11[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.26[${PYTHON_USEDEP}]
- >=dev-python/voluptuous-0.9.3[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
- dev-python/sphinx
- dev-python/pyyaml[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- virtual/jre
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- # avoid downloading from net
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
-
- # requests_aws4auth not in portage
- sed -e '/boto3/d' \
- -e '/requests_aws4auth/d' \
- -e 's/pyyaml==3.13/pyyaml/g' \
- -e '/tests_require/s/, "coverage", "nosexcover"//g' \
- -i setup.cfg setup.py || die
-
- # Bug 713342
- sed -i 's/yaml.load/yaml.unsafe_load/g' curator/utils.py test/unit/* || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- emake -C docs -j1 man $(usex doc html "")
-}
-
-# running tests in non-chroot environments:
-# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-curator
-python_test_all() {
- # starts two ES instances (local,remote) and runs the tests
- # https://github.com/elastic/curator/blob/master/travis-run.sh
- local ES_INSTANCES="local remote"
- local ES_PATH="${WORKDIR}/elasticsearch-${ES_VERSION}"
-
- declare -A ES_PORT
- ES_PORT[local]=9200
- ES_PORT[remote]=9201
-
- local i transport
- declare -A ES_CONFIG_DIR ES_CONFIG_PATH ES_INSTANCE ES_LOG ES_PID
- for i in ${ES_INSTANCES}; do
- ES_CONFIG_DIR[$i]="${ES_PATH}/$i"
- ES_CONFIG_PATH[$i]="${ES_CONFIG_DIR[$i]}/elasticsearch.yml"
- ES_PID[$i]="${ES_PATH}/$i.pid"
- ES_LOG[$i]="${ES_PATH}/logs/$i.log"
- done
-
- # configure ES instances
- for i in ${ES_INSTANCES}; do
- mkdir -p "${ES_CONFIG_DIR[$i]}" || die
- cp ${ES_PATH}/config/{jvm.options,log4j2.properties} "${ES_CONFIG_DIR[$i]}"/ || die
- echo 'network.host: 127.0.0.1' > "${ES_CONFIG_PATH[$i]}" || die
- echo "http.port: ${ES_PORT[$i]}" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "cluster.name: $i" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "node.name: $i" >> "${ES_CONFIG_PATH[$i]}" || die
- echo 'node.max_local_storage_nodes: 2' >> "${ES_CONFIG_PATH[$i]}" || die
- transport=$((${ES_PORT[$i]}+100))
- echo "transport.port: ${transport}" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "discovery.seed_hosts: [\"localhost:${transport}\"]" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "discovery.type: single-node" >> "${ES_CONFIG_PATH[$i]}" || die
- done
-
- echo 'path.repo: /' >> "${ES_CONFIG_PATH[local]}" || die
- echo "reindex.remote.whitelist: localhost:${ES_PORT[remote]}" >> "${ES_CONFIG_PATH[local]}" || die
-
- # start ES instances
- for i in ${ES_INSTANCES}; do
- ES_PATH_CONF=${ES_CONFIG_DIR[$i]} "${ES_PATH}/bin/elasticsearch" -d -p "${ES_PID[$i]}" || die
-
- local j
- local es_started=0
- for j in {1..30}; do
- grep -q "started" "${ES_LOG[$i]}" 2> /dev/null
- if [[ $? -eq 0 ]]; then
- einfo "Elasticsearch $i started"
- es_started=1
- eend 0
- break
- elif grep -q 'BindException\[Address already in use\]' "${ES_LOG[$i]}" 2>/dev/null; then
- eend 1
- eerror "Elasticsearch $i already running"
- die "Cannot start Elasticsearch $i for tests"
- else
- einfo "Waiting for Elasticsearch $i"
- eend 1
- sleep 2
- continue
- fi
- done
-
- [[ $es_started -eq 0 ]] && die "Elasticsearch failed to start"
- done
-
- export TEST_ES_SERVER="localhost:${ES_PORT[local]}"
- export REMOTE_ES_SERVER="localhost:${ES_PORT[remote]}"
-
- # run tests
- nosetests -v || die
-
- for i in ${ES_INSTANCES}; do
- pkill -F ${ES_PID[$i]}
- done
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- doman docs/_build/man/*
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- ewarn ""
- ewarn "For Python 3 support information please read: http://click.pocoo.org/latest/python3/"
- ewarn ""
- ewarn "Example usage on Python 3:"
- ewarn "export LC_ALL=en_US.UTF-8"
- ewarn "export LANG=en_US.UTF-8"
- ewarn "curator ..."
-}
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1-r3.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1-r3.ebuild
deleted file mode 100644
index 526bbb2aac47..000000000000
--- a/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1-r3.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-MY_PN="curator"
-ES_VERSION="7.3.2"
-
-inherit distutils-r1
-
-DESCRIPTION="Tending time-series indices in Elasticsearch"
-HOMEPAGE="https://github.com/elastic/curator"
-SRC_URI="https://github.com/elastic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-${ES_VERSION}-linux-x86_64.tar.gz )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# tests fail in chroot
-# https://github.com/elastic/elasticsearch/issues/12018
-RESTRICT="test"
-IUSE="doc test"
-
-# vulnerable pyyaml
-# https://github.com/elastic/curator/issues/1415
-RDEPEND="
- >=dev-python/elasticsearch-py-7.0.4[${PYTHON_USEDEP}]
- <dev-python/elasticsearch-py-8.0.0[${PYTHON_USEDEP}]
- >=dev-python/click-6.7[${PYTHON_USEDEP}]
- <dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/certifi-2019.9.11[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.26[${PYTHON_USEDEP}]
- >=dev-python/voluptuous-0.9.3[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
- dev-python/sphinx
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cx_Freeze[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- virtual/jre
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- # avoid downloading from net
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
-
- # requests_aws4auth not in portage
- sed -e '/boto3/d' \
- -e '/requests_aws4auth/d' \
- -e 's/pyyaml==3.13/pyyaml/g' \
- -e '/tests_require/s/, "coverage", "nosexcover"//g' \
- -i setup.cfg setup.py || die
-
- # Bug 713342
- sed -i 's/yaml.load/yaml.unsafe_load/g' curator/utils.py test/unit/* || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- emake -C docs -j1 man $(usex doc html "")
-}
-
-# running tests in non-chroot environments:
-# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-curator
-python_test_all() {
- # starts two ES instances (local,remote) and runs the tests
- # https://github.com/elastic/curator/blob/master/travis-run.sh
- local ES_INSTANCES="local remote"
- local ES_PATH="${WORKDIR}/elasticsearch-${ES_VERSION}"
-
- declare -A ES_PORT
- ES_PORT[local]=9200
- ES_PORT[remote]=9201
-
- local i transport
- declare -A ES_CONFIG_DIR ES_CONFIG_PATH ES_INSTANCE ES_LOG ES_PID
- for i in ${ES_INSTANCES}; do
- ES_CONFIG_DIR[$i]="${ES_PATH}/$i"
- ES_CONFIG_PATH[$i]="${ES_CONFIG_DIR[$i]}/elasticsearch.yml"
- ES_PID[$i]="${ES_PATH}/$i.pid"
- ES_LOG[$i]="${ES_PATH}/logs/$i.log"
- done
-
- # configure ES instances
- for i in ${ES_INSTANCES}; do
- mkdir -p "${ES_CONFIG_DIR[$i]}" || die
- cp ${ES_PATH}/config/{jvm.options,log4j2.properties} "${ES_CONFIG_DIR[$i]}"/ || die
- echo 'network.host: 127.0.0.1' > "${ES_CONFIG_PATH[$i]}" || die
- echo "http.port: ${ES_PORT[$i]}" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "cluster.name: $i" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "node.name: $i" >> "${ES_CONFIG_PATH[$i]}" || die
- echo 'node.max_local_storage_nodes: 2' >> "${ES_CONFIG_PATH[$i]}" || die
- transport=$((${ES_PORT[$i]}+100))
- echo "transport.port: ${transport}" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "discovery.seed_hosts: [\"localhost:${transport}\"]" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "discovery.type: single-node" >> "${ES_CONFIG_PATH[$i]}" || die
- done
-
- echo 'path.repo: /' >> "${ES_CONFIG_PATH[local]}" || die
- echo "reindex.remote.whitelist: localhost:${ES_PORT[remote]}" >> "${ES_CONFIG_PATH[local]}" || die
-
- # start ES instances
- for i in ${ES_INSTANCES}; do
- ES_PATH_CONF=${ES_CONFIG_DIR[$i]} "${ES_PATH}/bin/elasticsearch" -d -p "${ES_PID[$i]}" || die
-
- local j
- local es_started=0
- for j in {1..30}; do
- grep -q "started" "${ES_LOG[$i]}" 2> /dev/null
- if [[ $? -eq 0 ]]; then
- einfo "Elasticsearch $i started"
- es_started=1
- eend 0
- break
- elif grep -q 'BindException\[Address already in use\]' "${ES_LOG[$i]}" 2>/dev/null; then
- eend 1
- eerror "Elasticsearch $i already running"
- die "Cannot start Elasticsearch $i for tests"
- else
- einfo "Waiting for Elasticsearch $i"
- eend 1
- sleep 2
- continue
- fi
- done
-
- [[ $es_started -eq 0 ]] && die "Elasticsearch failed to start"
- done
-
- export TEST_ES_SERVER="localhost:${ES_PORT[local]}"
- export REMOTE_ES_SERVER="localhost:${ES_PORT[remote]}"
-
- # run tests
- nosetests -v || die
-
- for i in ${ES_INSTANCES}; do
- pkill -F ${ES_PID[$i]}
- done
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- doman docs/_build/man/*
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- ewarn ""
- ewarn "For Python 3 support information please read: http://click.pocoo.org/latest/python3/"
- ewarn ""
- ewarn "Example usage on Python 3:"
- ewarn "export LC_ALL=en_US.UTF-8"
- ewarn "export LANG=en_US.UTF-8"
- ewarn "curator ..."
-}
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.3.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.3.ebuild
deleted file mode 100644
index 7f6b7f539bfa..000000000000
--- a/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.3.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-MY_PN="curator"
-ES_VERSION="7.3.2"
-
-inherit distutils-r1
-
-DESCRIPTION="Tending time-series indices in Elasticsearch"
-HOMEPAGE="https://github.com/elastic/curator"
-SRC_URI="https://github.com/elastic/${MY_PN}/archive/V${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-${ES_VERSION}-linux-x86_64.tar.gz )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# tests fail in chroot
-# https://github.com/elastic/elasticsearch/issues/12018
-RESTRICT="test"
-IUSE="doc test"
-
-# vulnerable pyyaml
-# https://github.com/elastic/curator/issues/1415
-RDEPEND="
- >=dev-python/elasticsearch-py-7.0.4[${PYTHON_USEDEP}]
- <dev-python/elasticsearch-py-8.0.0[${PYTHON_USEDEP}]
- >=dev-python/click-6.7[${PYTHON_USEDEP}]
- <dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/certifi-2019.9.11[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.26[${PYTHON_USEDEP}]
- >=dev-python/voluptuous-0.9.3[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
- dev-python/sphinx
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cx_Freeze[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- virtual/jre
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- # avoid downloading from net
- sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
-
- # requests_aws4auth not in portage
- sed -e '/boto3/d' \
- -e '/requests_aws4auth/d' \
- -e 's/pyyaml==3.13/pyyaml/g' \
- -e '/tests_require/s/, "coverage", "nosexcover"//g' \
- -i setup.cfg setup.py || die
-
- # Bug 713342
- sed -i 's/yaml.load/yaml.unsafe_load/g' curator/utils.py test/unit/* || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- emake -C docs -j1 man $(usex doc html "")
-}
-
-# running tests in non-chroot environments:
-# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-curator
-python_test_all() {
- # starts two ES instances (local,remote) and runs the tests
- # https://github.com/elastic/curator/blob/master/travis-run.sh
- local ES_INSTANCES="local remote"
- local ES_PATH="${WORKDIR}/elasticsearch-${ES_VERSION}"
-
- declare -A ES_PORT
- ES_PORT[local]=9200
- ES_PORT[remote]=9201
-
- local i transport
- declare -A ES_CONFIG_DIR ES_CONFIG_PATH ES_INSTANCE ES_LOG ES_PID
- for i in ${ES_INSTANCES}; do
- ES_CONFIG_DIR[$i]="${ES_PATH}/$i"
- ES_CONFIG_PATH[$i]="${ES_CONFIG_DIR[$i]}/elasticsearch.yml"
- ES_PID[$i]="${ES_PATH}/$i.pid"
- ES_LOG[$i]="${ES_PATH}/logs/$i.log"
- done
-
- # configure ES instances
- for i in ${ES_INSTANCES}; do
- mkdir -p "${ES_CONFIG_DIR[$i]}" || die
- cp ${ES_PATH}/config/{jvm.options,log4j2.properties} "${ES_CONFIG_DIR[$i]}"/ || die
- echo 'network.host: 127.0.0.1' > "${ES_CONFIG_PATH[$i]}" || die
- echo "http.port: ${ES_PORT[$i]}" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "cluster.name: $i" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "node.name: $i" >> "${ES_CONFIG_PATH[$i]}" || die
- echo 'node.max_local_storage_nodes: 2' >> "${ES_CONFIG_PATH[$i]}" || die
- transport=$((${ES_PORT[$i]}+100))
- echo "transport.port: ${transport}" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "discovery.seed_hosts: [\"localhost:${transport}\"]" >> "${ES_CONFIG_PATH[$i]}" || die
- echo "discovery.type: single-node" >> "${ES_CONFIG_PATH[$i]}" || die
- done
-
- echo 'path.repo: /' >> "${ES_CONFIG_PATH[local]}" || die
- echo "reindex.remote.whitelist: localhost:${ES_PORT[remote]}" >> "${ES_CONFIG_PATH[local]}" || die
-
- # start ES instances
- for i in ${ES_INSTANCES}; do
- ES_PATH_CONF=${ES_CONFIG_DIR[$i]} "${ES_PATH}/bin/elasticsearch" -d -p "${ES_PID[$i]}" || die
-
- local j
- local es_started=0
- for j in {1..30}; do
- grep -q "started" "${ES_LOG[$i]}" 2> /dev/null
- if [[ $? -eq 0 ]]; then
- einfo "Elasticsearch $i started"
- es_started=1
- eend 0
- break
- elif grep -q 'BindException\[Address already in use\]' "${ES_LOG[$i]}" 2>/dev/null; then
- eend 1
- eerror "Elasticsearch $i already running"
- die "Cannot start Elasticsearch $i for tests"
- else
- einfo "Waiting for Elasticsearch $i"
- eend 1
- sleep 2
- continue
- fi
- done
-
- [[ $es_started -eq 0 ]] && die "Elasticsearch failed to start"
- done
-
- export TEST_ES_SERVER="localhost:${ES_PORT[local]}"
- export REMOTE_ES_SERVER="localhost:${ES_PORT[remote]}"
-
- # run tests
- nosetests -v || die
-
- for i in ${ES_INSTANCES}; do
- pkill -F ${ES_PID[$i]}
- done
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- doman docs/_build/man/*
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- ewarn ""
- ewarn "For Python 3 support information please read: http://click.pocoo.org/latest/python3/"
- ewarn ""
- ewarn "Example usage on Python 3:"
- ewarn "export LC_ALL=en_US.UTF-8"
- ewarn "export LANG=en_US.UTF-8"
- ewarn "curator ..."
-}
diff --git a/dev-python/elasticsearch-curator/metadata.xml b/dev-python/elasticsearch-curator/metadata.xml
deleted file mode 100644
index 31ed8d596996..000000000000
--- a/dev-python/elasticsearch-curator/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!--maintainer-needed-->
- <upstream>
- <remote-id type="github">elastic/curator</remote-id>
- <remote-id type="pypi">elasticsearch-curator</remote-id>
- </upstream>
-</pkgmetadata>