summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-28 13:34:21 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-28 14:00:56 +0200
commit666b6bf2383db89cfd61267f40fb652fd6a3a1a7 (patch)
tree001769b5ae80f6120b6264bb629a30c6c6dc1849 /dev-python
parentdev-python/hypothesis: Bump to 5.18.3 (diff)
downloadgentoo-666b6bf2383db89cfd61267f40fb652fd6a3a1a7.tar.gz
gentoo-666b6bf2383db89cfd61267f40fb652fd6a3a1a7.tar.bz2
gentoo-666b6bf2383db89cfd61267f40fb652fd6a3a1a7.zip
dev-python/tox: Bump to 3.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-3.16.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 06767d919a64..47c780f4afb1 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -5,4 +5,5 @@ DIST tox-3.14.5.tar.gz 290075 BLAKE2B 7e412e85981fe11cba4dc6a4ab3df824678b11fe59
DIST tox-3.15.0.tar.gz 291890 BLAKE2B 9c42c587332eafcfd02d2d8a42588af6253baf9f62e82eb8a8bf10da291b4868b1fe319e38a583bc67bb26ab868b8a123feccd5bd008ce618ceb46d3121c68d2 SHA512 cb21574301d953b361eb5e1d89eefe22e68ae5871036f03d5753ee97c888cadde548d62a50622dd65b3c488143bbbdf8d309bafa3b6a4807871c9e78b6fcdb9c
DIST tox-3.15.1.tar.gz 292044 BLAKE2B eb3062fb1a2494a6b23e1c6f2c6af56be5879664ae26918e60839d2f8cff98dc6b684a27469eac81c363a3cd3e90abdafe0ab4dc601840023e5263a42301f384 SHA512 334e2129d5418d4733a25419b81cc57e794a11954c21774231e32c93e977f1a7fb71c739adabccb5cdde9428ab69772e8623a0c0a1172855957f7cbcd4a917b1
DIST tox-3.15.2.tar.gz 293523 BLAKE2B a1a1c84a987d2b2e5194321405775ee3828b8e2c8dcd38c7e780a9d508b789a42f1880cffcecd68c50dfdc37008a4e9a117660fa2c732864c82af6c2eaf5a99e SHA512 9448554452c79039289d2d2c05c974f451647329701372c3e4b154a0161fa768245c0068cd5e3f1221b4b51a07be806f7c66ab9d4ef83a3e8e5964e18b9cde85
+DIST tox-3.16.0.tar.gz 294040 BLAKE2B 2f5ca2c1b0b839b4fe6834cba69d772b9605e6bb00b24d75867de768042cd091a8fd7f5a349867a5de578b96eaad9f59f2ad019203fc6b2c39c9efc6933d2d96 SHA512 f92accae643b01867749f10d01ba0e18ebb36071af55a21cd38ac8f14fa3db1b1e708b22f8601e4d1b172e59fb62588c1252d064be3fb6007002eeaaef716373
DIST tox-3.2.1.tar.gz 268827 BLAKE2B 764835d04fb0c17f32eb8e2041b83f90d6a729b781a5b5b95e9ecb1162f1c29ed595d4a6369524b390a31853b8003485b27a3a12d63e84f49e92675f1a9bee13 SHA512 79f5a1c8f6e818fbb8444754e3767d880fc1fdfe63b46c518d37440fe2b2f3ce572865aff83d9492c24486fded49893cc31bd9b11254bac4db507260304bc76f
diff --git a/dev-python/tox/tox-3.16.0.ebuild b/dev-python/tox/tox-3.16.0.ebuild
new file mode 100644
index 000000000000..0365e6a79004
--- /dev/null
+++ b/dev-python/tox/tox-3.16.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
+ ' python3_{5,6,7} pypy3)
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ =dev-python/tox-${PV}-${PR}[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # broken without internet
+ sed -i -e 's:test_provision_non_canonical_dep:_&:' \
+ tests/unit/session/test_provision.py || die
+ sed -i -e 's:test_provision_interrupt_child:_&:' \
+ tests/integration/test_provision_int.py || die
+ # broken with our mock version (?)
+ sed -i -e 's:test_create_KeyboardInterrupt:_&:' \
+ tests/unit/test_venv.py || die
+ # broken with Gentoo Python layout
+ sed -i -e 's:test_tox_get_python_executable:_&:' \
+ -e 's:test_find_alias_on_path:_&:' \
+ tests/unit/interpreters/test_interpreters.py || die
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv --no-network || die "Testsuite failed under ${EPYTHON}"
+}