summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-15 10:09:01 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-15 10:10:31 +0200
commit6800eaeb8bc9bcaaf1169b404d6509d68be71a63 (patch)
treedd13f93a4411404563b41076ac6d82a61a721fdb /dev-python
parentdev-util/shellcheck: Bump to 0.7.0 (diff)
downloadgentoo-6800eaeb8bc9bcaaf1169b404d6509d68be71a63.tar.gz
gentoo-6800eaeb8bc9bcaaf1169b404d6509d68be71a63.tar.bz2
gentoo-6800eaeb8bc9bcaaf1169b404d6509d68be71a63.zip
dev-python/pypy3: Restore non-SSE2 x86 backend
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy3/pypy3-7.1.1.ebuild25
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild25
2 files changed, 46 insertions, 4 deletions
diff --git a/dev-python/pypy3/pypy3-7.1.1.ebuild b/dev-python/pypy3/pypy3-7.1.1.ebuild
index f0f7cdf74a2a..344f0da4013e 100644
--- a/dev-python/pypy3/pypy3-7.1.1.ebuild
+++ b/dev-python/pypy3/pypy3-7.1.1.ebuild
@@ -17,7 +17,8 @@ LICENSE="MIT"
# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
SLOT="0/71-py36"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 gdbm +jit libressl low-memory ncurses sandbox sqlite tk"
+IUSE="bzip2 cpu_flags_x86_sse2 gdbm +jit libressl low-memory ncurses
+ sandbox sqlite tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
@@ -103,12 +104,32 @@ src_prepare() {
src_configure() {
tc-export CC
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
local args=(
--shared
$(usex jit -Ojit -O2)
$(usex sandbox --sandbox '')
- --jit-backend=auto
+ ${jit_backend}
pypy/goal/targetpypystandalone
)
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index ca7aae03fe83..d6e6b0856eab 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -20,7 +20,8 @@ LICENSE="MIT"
# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
SLOT="0/71-py36"
KEYWORDS=""
-IUSE="bzip2 gdbm +jit libressl low-memory ncurses sandbox sqlite tk"
+IUSE="bzip2 cpu_flags_x86_sse2 gdbm +jit libressl low-memory ncurses
+ sandbox sqlite tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
@@ -111,12 +112,32 @@ src_prepare() {
src_configure() {
tc-export CC
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
local args=(
--shared
$(usex jit -Ojit -O2)
$(usex sandbox --sandbox '')
- --jit-backend=auto
+ ${jit_backend}
pypy/goal/targetpypystandalone
)