summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-15 16:41:16 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-15 16:41:21 +0200
commit6905d8910b1be32ead99327b47fada5e02ad247a (patch)
tree52bf9c2f35d0db8b46e1328b097baa862098fd23 /dev-python
parentdev-python/testrepository: Version Bump (diff)
downloadgentoo-6905d8910b1be32ead99327b47fada5e02ad247a.tar.gz
gentoo-6905d8910b1be32ead99327b47fada5e02ad247a.tar.bz2
gentoo-6905d8910b1be32ead99327b47fada5e02ad247a.zip
dev-python/fixtures: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fixtures/Manifest1
-rw-r--r--dev-python/fixtures/fixtures-1.4.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/fixtures/Manifest b/dev-python/fixtures/Manifest
index e77ecb0acf1b..378a9d0826b8 100644
--- a/dev-python/fixtures/Manifest
+++ b/dev-python/fixtures/Manifest
@@ -2,3 +2,4 @@ DIST fixtures-0.3.14.tar.gz 34586 SHA256 4cc3313e52519d2671bd22aacd4b3fde9d96b31
DIST fixtures-1.2.0.tar.gz 45318 SHA256 bb3b677a069d9fc3eb0fbc452965ac8a6c95edc778f3bd05b789ed46d1527b01 SHA512 c2730a2bb1cd5d7fbdf0499fa3cf3b62063d4632207a15e40fa0f6a4ccc0fa0afa786a115ac02cf01eaaac931ea1927bf979ffd446ec41d324862b3f69a8e9c7 WHIRLPOOL 322af23609b331023d03a27305c22e9b078f9d7f08924e217b525a5a64b6c28eec7262c9500cb3fe830095a7a693d0bdc84f952525d94bb1e7e56e627590eb8d
DIST fixtures-1.3.0.tar.gz 48941 SHA256 81c43b99ee63b2849a7a07c2ddcf147dea0c36260cd71352b649397d427d8f30 SHA512 48bcfd125af25cb594a01b5509730acf1ab8dcc3b19d67c572bad8fb4cd837bd02caa3086bd937fcf5e0ff72cf404988333899471103f37ecff54445e928e433 WHIRLPOOL e871e2092eecadf8a1b1fcd568d3704962e5b03b8374ec3bfee74dedbc1dee5efc3d24b1054e3424ed64830e2f94b1828948810052ef3dccfe5f9051df64c920
DIST fixtures-1.3.1.tar.gz 49741 SHA256 b63cf3bb37f83ff815456e2d0e118535ae9a4bf43e76d9a1cf3286041bf717ce SHA512 ce6ec1e1edeca34cdca86ca802cf1a468dde141f1ce2345ae9d9fd797e5ae4f9d69f9adbbbc90c6f8f070c6e75932f6d34f08a2f3d2d3109c7c7334cc4e3fe68 WHIRLPOOL 9b94c3a727ad46bee4cb99c2b907c0f38c7a2cf07846abfa90f8996849313dbf27d26742565853eaa580ddd9d42a3176ce691dd25fee5cdd8a1046866bb46695
+DIST fixtures-1.4.0.tar.gz 50411 SHA256 3e1c61753d0fafc1429591d33ad6b828a0673a200eae63dd6ac0685479db5d36 SHA512 62e314821ea507ab5c1465fb626c29c91430b36ae4670fd05a3aa7180452989c393d35ab623da3646b25cf671a84861ab68d9529d04ae759c0d38efca7c7d8cf WHIRLPOOL ad2b0ebf50a01aad4ec6924511eb3d174ebf4ac11306ed2873896380456a20e3fc5b7d84791035cffdc77561664f09f04935ef73246554110df756d8213d469a
diff --git a/dev-python/fixtures/fixtures-1.4.0.ebuild b/dev-python/fixtures/fixtures-1.4.0.ebuild
new file mode 100644
index 000000000000..af97575a95c0
--- /dev/null
+++ b/dev-python/fixtures/fixtures-1.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+RDEPEND="
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+#DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ emake check
+}