summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-25 05:07:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-25 07:11:32 +0200
commit6913b59c9fed4e5955b56889812f6912d79692d6 (patch)
tree4715f270a0e067d3da0c7c5f04d814f6fd923ba3 /dev-python
parentdev-python/pyfeyn: treeclean (diff)
downloadgentoo-6913b59c9fed4e5955b56889812f6912d79692d6.tar.gz
gentoo-6913b59c9fed4e5955b56889812f6912d79692d6.tar.bz2
gentoo-6913b59c9fed4e5955b56889812f6912d79692d6.zip
dev-python/botocore: Bump to 1.27.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.17.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9424a3fec702..8b4b193c6de2 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,4 +3,5 @@ DIST botocore-1.27.13.tar.gz 9134638 BLAKE2B 471a46a4c4f14082ceb7030495a121ea90a
DIST botocore-1.27.14.tar.gz 9134503 BLAKE2B ca29a33c5363457053f8ac042279726a15d3dc5f72546558d11bbacd79e7641d94b1137b76e201ad00203ecff53274fd41abd9178e7abbc1c5a51fe388f7fa5e SHA512 3995918212559eab009f141f94e6e6496fc77f12438e1dd62ce3ee232009b90de3882d342d20e83eb11de5f35b7878f53eea884016874caacb9d2e3d167b4f1a
DIST botocore-1.27.15.tar.gz 9134585 BLAKE2B 33fcf026334e0be28b7f20b78e072d4eed85e857438319dfe6a1aefb2aeb287aa7a4d6b5f40cd47b9ca5e904263bd7716e58fe2962a75fa64ffea8da383fd527 SHA512 15a65137b131220863fc7fb4c085d83b858a673ee49370bc8d5ce8433f2ee3c99dffd102830da10ed1c4fa4a6f5fdc5f543be4e88646f981409fb855ea100932
DIST botocore-1.27.16.tar.gz 9138117 BLAKE2B ed636cd031445b14f57282326836616dca626c27ff912b5a2014df83c5574264f773d9ab8aae2f01b55bb810d00233f1a4cceb0f746767247b5954bb8739b7be SHA512 c4b1debe648cd3027fe409f4ec095a4b454050ec427e8a11e04bc1f82d452566d2168dd539d5dc687e46e612f3d47e218d99de9510156e19eac477ea3c0259d2
+DIST botocore-1.27.17.tar.gz 9130505 BLAKE2B 04c6b37f3b42a0f9fb696b5213338b004418a68c754f5027ad447119fb20556dc49bd53f40fd9560ea3f5bdcf2afbe151dba68e901079baec770f9f223b1a894 SHA512 b1a145d3c97adfd4df40639da99e1c34087508be189d5818ee7176f20454f2897a6f518a14b4bfbf41cb169a17188bec467337c10d0ad511e223f0c1ff5b64ee
DIST botocore-1.27.7.tar.gz 9102259 BLAKE2B 094ec463531f1dfd54ff32d0f44ebc39cdc0a6d4c3e19b49a25e25d9d13acdcd26c782c1d4819ea4f1cb8954a858aa6e997411785678700b7ca03cd8844527b5 SHA512 d4a1327f4314279548af00fbc6da2f9fc5f25f704da3f6ddfa90773878f28ac9f03556b00fa4c0207ec2e952eb716aa98c1c22abffbd51d82dc55d9e4ceeca5c
diff --git a/dev-python/botocore/botocore-1.27.17.ebuild b/dev-python/botocore/botocore-1.27.17.ebuild
new file mode 100644
index 000000000000..830c713f6036
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.17.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}