summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-04 16:41:57 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-04 18:58:03 -0400
commit6a189c83547dd889e0075ec1bc893ff01103f596 (patch)
treed9c70ca654c878650827a197f48094dfb015c62a /dev-python
parentdev-python/jupyter: drop py2 (diff)
downloadgentoo-6a189c83547dd889e0075ec1bc893ff01103f596.tar.gz
gentoo-6a189c83547dd889e0075ec1bc893ff01103f596.tar.bz2
gentoo-6a189c83547dd889e0075ec1bc893ff01103f596.zip
dev-python/jupyter_core: drop py2
Bug: https://bugs.gentoo.org/685040 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild b/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..994c0dea0944
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.4.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+# tests require installation of jupyter_core, bug #649538
+RESTRICT="test"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test jupyter_core || die
+}