summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 15:38:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 15:41:11 +0200
commit6aa6e498105c16f10e70f128b7f154daae120ca3 (patch)
tree600d869b861ec319d0f845425213b500c4138b08 /dev-python
parentnet-misc/streamlink: Enable py3.9 (diff)
downloadgentoo-6aa6e498105c16f10e70f128b7f154daae120ca3.tar.gz
gentoo-6aa6e498105c16f10e70f128b7f154daae120ca3.tar.bz2
gentoo-6aa6e498105c16f10e70f128b7f154daae120ca3.zip
dev-python/pycountry: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycountry/pycountry-20.7.3.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/dev-python/pycountry/pycountry-20.7.3.ebuild b/dev-python/pycountry/pycountry-20.7.3.ebuild
index 24c4be17dd8d..124a682416fb 100644
--- a/dev-python/pycountry/pycountry-20.7.3.ebuild
+++ b/dev-python/pycountry/pycountry-20.7.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
# The package uses pkg_resources to determine its version
DISTUTILS_USE_SETUPTOOLS=manual
@@ -16,20 +16,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm64 ~ia64 ppc ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests --install pytest
# https://github.com/flyingcircusio/pycountry/pull/51
PATCHES=( "${FILESDIR}/${P}-fix-tests-for-pypy3.patch" )
-
-python_test() {
- # The package uses pkg_resources to determine its version
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}