summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 08:03:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 08:03:51 +0200
commit6af912e5c5acdf28fed4a6a078b2b6e90e3df107 (patch)
treeb95183ed96a0d4d34bf66ff55b62f6f30d975cb1 /dev-python
parentdev-python/cli_helpers: Port to py3.9 (diff)
downloadgentoo-6af912e5c5acdf28fed4a6a078b2b6e90e3df107.tar.gz
gentoo-6af912e5c5acdf28fed4a6a078b2b6e90e3df107.tar.bz2
gentoo-6af912e5c5acdf28fed4a6a078b2b6e90e3df107.zip
dev-python/hypothesis: Bump to 5.23.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.23.7.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index c7e8967558bf..79b4624a8341 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -10,3 +10,4 @@ DIST hypothesis-python-5.20.3.tar.gz 9024258 BLAKE2B 75bc1e868061be9c8d0377143f5
DIST hypothesis-python-5.21.0.tar.gz 9025422 BLAKE2B acd6f3b0f945ae65656af2a718add06fe440e221fda7793e3557ab194ccee4c6327e7946a58ce51e9efe3c08274888a648d9021c49fdcf663a04c28b99a0f636 SHA512 1921e5ea8d0f2a6e55d80611004d35671f7a7a02cb8a8f101b45e64e4ef23f9c2c8a9c467fb6c9f33ae440622020e1ad504f51a7d725a6449ca715ad1f373e40
DIST hypothesis-python-5.23.1.tar.gz 9031807 BLAKE2B 00c54296f83bdcd41ac63b36a29dc9e542a236406609b9b800912a209d56c4169f2d4b1c139697ffe38eff6cd886cd4a2491f3b4b5294cc710aedb70f5905436 SHA512 b6da23a586b60b5a094dddccab82f3b863cebcde5103e492807fb9e0b9d047b3e5fe928da24eabf5764298332d9c1e9b434ef167d7cff0a9de8a175d5f9964a5
DIST hypothesis-python-5.23.3.tar.gz 9032683 BLAKE2B 629a44b3dbfd206c259413df44143e38d045b915d3b85359e199064aae20ec3b6946d856fbb2a9c702c765f5cd69c4418ad009fa79d6cc6eb196c2662e4254bc SHA512 15d4b3b57c234f970bebf7bd98a75a5ac031422b3f70848d25a8ee94852a3f73f8b3e1d69ee850144f1f229d1dbe18fa7959df1930fc42a5768ac7e3d6bb9e7b
+DIST hypothesis-python-5.23.7.tar.gz 9037231 BLAKE2B 0f0e2b700dfaaf4e29b950ec38ef9ba6b1aaf5a90f3266def8f895c35e4a0e8104258c86c30fca49f2239106d032c306a7a520e0b1976a87d4b50b3314c5ff2d SHA512 9e4a52d149f84b895cb72ab955997caf1070f778ae15c3401602ba86ca0cbe7ea2a6603821bd7c0d79ce59bb41adb21e0cb11f22ab179e9657784c2da40685f2
diff --git a/dev-python/hypothesis/hypothesis-5.23.7.ebuild b/dev-python/hypothesis/hypothesis-5.23.7.ebuild
new file mode 100644
index 000000000000..54efc2972e96
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.23.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}