summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-10 21:00:42 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-10 21:06:36 +0200
commit6d51d73f0226fc011caa7946c0cc17cbbb496a5f (patch)
tree641d74eebdee6c1a68ebfc7d707d2a92965e7c81 /dev-python
parentdev-util/buildbot-badges: Version bump to 2.8.4 (diff)
downloadgentoo-6d51d73f0226fc011caa7946c0cc17cbbb496a5f.tar.gz
gentoo-6d51d73f0226fc011caa7946c0cc17cbbb496a5f.tar.bz2
gentoo-6d51d73f0226fc011caa7946c0cc17cbbb496a5f.zip
dev-python/plyvel: bump to 1.3.0, simplify the test logic
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/plyvel/Manifest1
-rw-r--r--dev-python/plyvel/plyvel-1.3.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/plyvel/Manifest b/dev-python/plyvel/Manifest
index b3a5bfdc33cf..c3d7e52c0436 100644
--- a/dev-python/plyvel/Manifest
+++ b/dev-python/plyvel/Manifest
@@ -1 +1,2 @@
DIST plyvel-1.2.0.tar.gz 145528 BLAKE2B 3a1604b536e462b3eccb7c8294c607828b8f41f3ead65c74fd200d3bb4179765d63f57508cb3bfaee1c4c57ecda7b986afe9416714ae74ed9ad35a9247397c98 SHA512 00b3424e248d1ed17f6443c9862c9f35c94ad76707df5adfe625d7a387620252ff71b3e1f7e903dda1c5cfcd53cb23883c1049e31df541dfe566b8e849c0a96d
+DIST plyvel-1.3.0.tar.gz 149379 BLAKE2B 0a4fc8c3073cc8e103ab217f8e7971f04d9e6d1862dea7ce3d2634ba9646bdeebdda740fe6cb2e83aeeab513601bddef374355c4f6c9f320ce6b4b14ff2b2bf6 SHA512 fc1b84f0e98bf3edcdc2d7eda4f18313186538bb419bd297f694330e60512a6ab63e8d2fabaa825023eb5570f175ebbc22b8ae81e29603b1a94c1abb37774e99
diff --git a/dev-python/plyvel/plyvel-1.3.0.ebuild b/dev-python/plyvel/plyvel-1.3.0.ebuild
new file mode 100644
index 000000000000..b49ff2018566
--- /dev/null
+++ b/dev-python/plyvel/plyvel-1.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to LevelDB"
+HOMEPAGE="https://github.com/wbolster/plyvel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/leveldb-1.20:="
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_test() {
+ # With the default import mode, plyvel is imported from ${S} which causes
+ # a failure because it doesn't contain the compiled _plyvel extension
+ pytest --import-mode=append -vv || die "Tests fail with ${EPYTHON}"
+}