summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-25 13:24:15 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-25 13:24:27 +0100
commit6fbcb03b918df48f33d24326640209de3d031074 (patch)
treecf35171099ddf00c48d2e448d616aae810bd3a3e /dev-python
parentpackage.mask: fix category for boost-build (diff)
downloadgentoo-6fbcb03b918df48f33d24326640209de3d031074.tar.gz
gentoo-6fbcb03b918df48f33d24326640209de3d031074.tar.bz2
gentoo-6fbcb03b918df48f33d24326640209de3d031074.zip
dev-python/python-poppler: Add fixes for poppler-0.39.0
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=568948 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-poppler/files/python-poppler-0.12.1-poppler-0.39.0-changes.patch19
-rw-r--r--dev-python/python-poppler/python-poppler-0.12.1-r4.ebuild2
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-poppler/files/python-poppler-0.12.1-poppler-0.39.0-changes.patch b/dev-python/python-poppler/files/python-poppler-0.12.1-poppler-0.39.0-changes.patch
new file mode 100644
index 000000000000..dd3ee52ad46d
--- /dev/null
+++ b/dev-python/python-poppler/files/python-poppler-0.12.1-poppler-0.39.0-changes.patch
@@ -0,0 +1,19 @@
+--- poppler.defs 2009-09-27 16:07:59.000000000 +0700
++++ poppler.defs 2015-12-22 16:36:14.000000000 +0600
+@@ -579,16 +579,4 @@
+ )
+
+-(define-enum Orientation
+- (in-module "Poppler")
+- (c-name "PopplerOrientation")
+- (gtype-id "POPPLER_TYPE_ORIENTATION")
+- (values
+- '("portrait" "POPPLER_ORIENTATION_PORTRAIT")
+- '("landscape" "POPPLER_ORIENTATION_LANDSCAPE")
+- '("upsidedown" "POPPLER_ORIENTATION_UPSIDEDOWN")
+- '("seascape" "POPPLER_ORIENTATION_SEASCAPE")
+- )
+-)
+-
+ (define-enum PageTransitionType
+ (in-module "Poppler")
diff --git a/dev-python/python-poppler/python-poppler-0.12.1-r4.ebuild b/dev-python/python-poppler/python-poppler-0.12.1-r4.ebuild
index 6da0020a1a12..b9dbfea911c9 100644
--- a/dev-python/python-poppler/python-poppler-0.12.1-r4.ebuild
+++ b/dev-python/python-poppler/python-poppler-0.12.1-r4.ebuild
@@ -3,6 +3,7 @@
# $Id$
EAPI="5"
+
PYTHON_COMPAT=( python2_7 )
inherit autotools-utils eutils python-r1
@@ -31,6 +32,7 @@ PATCHES=(
"${FILESDIR}"/${P}-79_78.diff
"${FILESDIR}"/${P}-poppler0.15.0-changes.patch
"${FILESDIR}"/${P}-poppler-0.18.0-minimal-fix.patch
+ "${FILESDIR}"/${P}-poppler-0.39.0-changes.patch
)
src_configure() {