summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-30 03:31:33 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-30 03:31:33 -0600
commit700eaf0092c1704b9302d4c496a43477acb4be94 (patch)
treeae505b282659d63b8295139c081a190fdd9b5926 /dev-python
parentdev-python/pyopenssl: version bump to 18.0.0 (diff)
downloadgentoo-700eaf0092c1704b9302d4c496a43477acb4be94.tar.gz
gentoo-700eaf0092c1704b9302d4c496a43477acb4be94.tar.bz2
gentoo-700eaf0092c1704b9302d4c496a43477acb4be94.zip
dev-python/hypothesis: version bump to 3.85.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-3.85.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 5689596eb725..8ff8ddff2ae8 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-3.6.0.tar.gz 73586 BLAKE2B b0ec133e8c71f752114211061155c15a7d536
DIST hypothesis-python-3.59.1.tar.gz 500529 BLAKE2B 5c171045e363f2337d7ca30797b9fc7f96430c805dd4b3ec78fe927247d2c2ba4a216789a82f1e956b89d66c5ecdb2050a5f93467f2d557a05d1d48507fc06db SHA512 c3aad4cc54152963806e09af5f351e60e30cd64ad48ba3d922451b10dbb1747ea3e5d432ebc611dcb0646687d7e8755051b967304e74798d091be0b2901c832f
DIST hypothesis-python-3.74.3.tar.gz 552616 BLAKE2B e19a0991e7ae2fa6208c81d336cc66e3392bb78663f567fe28b570a1463a5359ccf713776f1f9cbd19a27a53b9a71a5be6eedfa05599fa12c047c373aa339592 SHA512 f4927d6e908a9222fa06f82ad6e4cf90c62a0a3d0c7632c17ee57a3705239901fcb5dbbcfca402c153bf2bea9dde0e51c852d2024ed5a236888327963fe13a3e
DIST hypothesis-python-3.83.1.tar.gz 564466 BLAKE2B 7b4c00a46b5a547bfc98711b795525c09d91ed41ac2c1dcf9c3c571e32819c77c6f6a4311ff32020a6d8e837dfcd03f7e2d842613148201d476615831483a737 SHA512 d828dbfe8637b6388b8c77af08970c2b45cd8f6960f26b1c54f3fbeba012e225d116802cae70ee28321de9d961397e60a5ff8cbefc02d085b6f6978f6bddf56e
+DIST hypothesis-python-3.85.1.tar.gz 568995 BLAKE2B 65297e73ec833beee05f7ad4f137cdbfe1b28cc478df31fedf8fc2c5183e70c10d5254fdba906842551fcfb7280ac59b3a7dc5cf752700c770c90d158cb81324 SHA512 cf6951d8cb70539b57147f422e43296518edf416200eec220f0c3f258ee6215f858e496f66b340ea68d1754cd936fc26a4ce4d1ee7a38cf338398d316c06cc24
diff --git a/dev-python/hypothesis/hypothesis-3.85.1.ebuild b/dev-python/hypothesis/hypothesis-3.85.1.ebuild
new file mode 100644
index 000000000000..5e0c71eda1d2
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.85.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/attrs-16.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+python_test() {
+ pytest tests/cover/test_testdecorators.py || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}