summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-11 21:33:05 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-11 21:33:27 +0200
commit71964f6f257ef9120705438993d8ebc1d725a480 (patch)
tree393b36d1240be8054714afa10586dddc8d9e97f0 /dev-python
parentdev-python/jinja: Remove old (diff)
downloadgentoo-71964f6f257ef9120705438993d8ebc1d725a480.tar.gz
gentoo-71964f6f257ef9120705438993d8ebc1d725a480.tar.bz2
gentoo-71964f6f257ef9120705438993d8ebc1d725a480.zip
dev-python/psutil: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/psutil/Manifest1
-rw-r--r--dev-python/psutil/psutil-5.6.7-r1.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index 50a5c6357b23..ddf005a6240b 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -1,2 +1 @@
-DIST psutil-5.6.7.tar.gz 448321 BLAKE2B 4e47fb7def5a0eed162686d4e90dd122bd380eca50c3294cd89ed154e27f71972dbc2b3b481456d5022107a1adad2a637e8f233002d429463232c38a04a957c7 SHA512 74eb488b91764941e38214f07bca00e3c837167ad543bfd9ae3b83d665e2be1bb5341eca4aff9282ad50d321568a679e1ffa2ee72ad7b4965cda92b7c80b2503
DIST psutil-5.7.0.tar.gz 449628 BLAKE2B 3bd07a0a2f95a539910fa1cef92e72d168c3ee7a495c0defd3fad307d96448d81182b7ccc5e4388d6726495a18df26b076e27b3cbf57096a5c3c8326c00f2dea SHA512 8cee64ab396dae79866e961aeabdb9a4174e1339bcd5c0a35f23fee97ca2a61c0cb08f7152d7e0db90c387400c5c6fb3da2dd2124ce9bf97dfffe6f3b4967981
diff --git a/dev-python/psutil/psutil-5.6.7-r1.ebuild b/dev-python/psutil/psutil-5.6.7-r1.ebuild
deleted file mode 100644
index b4de013113ed..000000000000
--- a/dev-python/psutil/psutil-5.6.7-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/ipaddress[${PYTHON_USEDEP}]
- ' -2)
- )
-"
-
-PATCHES=(
- "${FILESDIR}/psutil-5.6.7-tests.patch"
-)
-
-python_test() {
- if [[ ${EPYTHON} == pypy* ]]; then
- ewarn "Not running tests on ${EPYTHON} since they are broken"
- return 0
- fi
-
- # since we are running in an environment a bit similar to CI,
- # let's skip the tests that are disable for CI
- TRAVIS=1 APPVEYOR=1 "${EPYTHON}" psutil/tests/__main__.py ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_compile() {
- # force -j1 to avoid .o linking race conditions
- local MAKEOPTS=-j1
- distutils-r1_python_compile
-}