summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-02 14:28:06 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-02 14:29:07 +0100
commit7274dd75f1a690771fc84c7b283360eb45333029 (patch)
treeb8506cc0441308bf36bbe11d0fd857d2db14a0dc /dev-python
parentmedia-gfx/fotoxx: add 22.40 (diff)
downloadgentoo-7274dd75f1a690771fc84c7b283360eb45333029.tar.gz
gentoo-7274dd75f1a690771fc84c7b283360eb45333029.tar.bz2
gentoo-7274dd75f1a690771fc84c7b283360eb45333029.zip
dev-python/spyder: unpin dep on qdarkstyle
and update the documentation while at it. Closes: https://bugs.gentoo.org/857564 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/spyder/Manifest2
-rw-r--r--dev-python/spyder/files/spyder-5.3.3-unpin-qdarkstyle.patch26
-rw-r--r--dev-python/spyder/spyder-5.3.3-r1.ebuild (renamed from dev-python/spyder/spyder-5.3.3.ebuild)4
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/spyder/Manifest b/dev-python/spyder/Manifest
index 3b0cb80ad1a7..b6f3257168e2 100644
--- a/dev-python/spyder/Manifest
+++ b/dev-python/spyder/Manifest
@@ -1,2 +1,2 @@
DIST spyder-5.3.3.gh.tar.gz 24443628 BLAKE2B 767b3e1d59ce650d2df0d229d94eef53bc4c7b52f5d40fd62748efeb3a756a773110aa17442403a1b37777dd39fc367164ad54cd8f767d4311caa8d3e8bf05da SHA512 7d521f8367953849233538cbfd74f1fd98da87e69dbed8076718e81cd09ae66aca84523c4ecdf0e8aeb60644791754df19f09dd244ce11e3f7decc97bb050e02
-DIST spyder-docs-9156f446a9225446a2a752ecb669cc3db30094a8.gh.tar.gz 90029977 BLAKE2B 7254da77f6d9dd24d9feb8af684d064bb92400acf1561f8a2b9423c63984c22fb3ab384174f87525c3cdb0612590fb97010e9cd1a21ae1e36ffc6d6f9babe973 SHA512 1a9609baea12059fad1e65b84c1db98e15cb3d65e1c60660a1f1ebeab5723b118d6e995a4e4219391d8aafb640da20e2a4984746e9c66893dd0cef2ea3f082f9
+DIST spyder-docs-bb9b308b66cc90e47f43418f079bf098eb4efe6c.gh.tar.gz 89966852 BLAKE2B 7698b0210ccfec9f00cc76893f49398a02878c732eba6bbc89c1da4514734aad8ae8ef85a9c701a1d194976a35a8092755f7c5f09b319f670fac21d0a2e6c542 SHA512 9dd428ca2623c5703076887ab593bd92a2e737d74eb914a7a186d2ab4855519abb02875226463d8c11ff5021e7e84a5ba7c200ad5476f0dc4646831bb0b197a1
diff --git a/dev-python/spyder/files/spyder-5.3.3-unpin-qdarkstyle.patch b/dev-python/spyder/files/spyder-5.3.3-unpin-qdarkstyle.patch
new file mode 100644
index 000000000000..b9939a95cc53
--- /dev/null
+++ b/dev-python/spyder/files/spyder-5.3.3-unpin-qdarkstyle.patch
@@ -0,0 +1,26 @@
+diff --git a/setup.py b/setup.py
+index 176c07f..d73d195 100644
+--- a/setup.py
++++ b/setup.py
+@@ -231,7 +231,7 @@ install_requires = [
+ 'python-lsp-server[all]>=1.5.0,<1.6.0',
+ 'pyxdg>=0.26;platform_system=="Linux"',
+ 'pyzmq>=22.1.0',
+- 'qdarkstyle>=3.0.2,<3.1.0',
++ 'qdarkstyle>=3.0.2',
+ 'qstylizer>=0.1.10',
+ 'qtawesome>=1.0.2',
+ 'qtconsole>=5.3.2,<5.4.0',
+diff --git a/spyder/dependencies.py b/spyder/dependencies.py
+index 18fd9d4..50d1a6c 100644
+--- a/spyder/dependencies.py
++++ b/spyder/dependencies.py
+@@ -57,7 +57,7 @@ PYLSP_BLACK_REQVER = '>=1.2.0'
+ PYLS_SPYDER_REQVER = '>=0.4.0'
+ PYXDG_REQVER = '>=0.26'
+ PYZMQ_REQVER = '>=22.1.0'
+-QDARKSTYLE_REQVER = '>=3.0.2;<3.1.0'
++QDARKSTYLE_REQVER = '>=3.0.2'
+ QSTYLIZER_REQVER = '>=0.1.10'
+ QTAWESOME_REQVER = '>=1.0.2'
+ QTCONSOLE_REQVER = '>=5.3.2;<5.4.0'
diff --git a/dev-python/spyder/spyder-5.3.3.ebuild b/dev-python/spyder/spyder-5.3.3-r1.ebuild
index 6ed0d7ebe359..4cc2c5bd76de 100644
--- a/dev-python/spyder/spyder-5.3.3.ebuild
+++ b/dev-python/spyder/spyder-5.3.3-r1.ebuild
@@ -9,7 +9,7 @@ DISTUTILS_USE_PEP517=setuptools
inherit optfeature xdg distutils-r1
# Commit of documentation to fetch
-DOCS_PV="9156f446a9225446a2a752ecb669cc3db30094a8"
+DOCS_PV="bb9b308b66cc90e47f43418f079bf098eb4efe6c"
DESCRIPTION="The Scientific Python Development Environment"
HOMEPAGE="
@@ -51,7 +51,6 @@ RDEPEND="
>=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
>=dev-python/pyzmq-22.1.0[${PYTHON_USEDEP}]
>=dev-python/qdarkstyle-3.0.2[${PYTHON_USEDEP}]
- <dev-python/qdarkstyle-3.1[${PYTHON_USEDEP}]
>=dev-python/qstylizer-0.1.10[${PYTHON_USEDEP}]
>=dev-python/qtawesome-1.0.2[${PYTHON_USEDEP}]
>=dev-python/qtconsole-5.3.2[${PYTHON_USEDEP}]
@@ -89,6 +88,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-5.0.0-build.patch"
"${FILESDIR}/${PN}-5.2.0-doc-theme-renamed.patch"
+ "${FILESDIR}/${PN}-5.3.3-unpin-qdarkstyle.patch"
)
DOCS=(