summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-19 21:10:04 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-19 21:13:20 +0200
commit730558846ac4f98080ac21cdd3d008d0e153d2c3 (patch)
treeb9640df1030e46c370a776b489338cefa39fa9d0 /dev-python
parentdev-python/xstatic-patternfly: new package. (diff)
downloadgentoo-730558846ac4f98080ac21cdd3d008d0e153d2c3.tar.gz
gentoo-730558846ac4f98080ac21cdd3d008d0e153d2c3.tar.bz2
gentoo-730558846ac4f98080ac21cdd3d008d0e153d2c3.zip
dev-python/xstatic-patternfly-bootstrap-treeview: new package.
Dependency of ARA. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xstatic-patternfly-bootstrap-treeview/Manifest1
-rw-r--r--dev-python/xstatic-patternfly-bootstrap-treeview/metadata.xml11
-rw-r--r--dev-python/xstatic-patternfly-bootstrap-treeview/xstatic-patternfly-bootstrap-treeview-2.1.3.2.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/xstatic-patternfly-bootstrap-treeview/Manifest b/dev-python/xstatic-patternfly-bootstrap-treeview/Manifest
new file mode 100644
index 000000000000..2e0070db328c
--- /dev/null
+++ b/dev-python/xstatic-patternfly-bootstrap-treeview/Manifest
@@ -0,0 +1 @@
+DIST xstatic-patternfly-bootstrap-treeview-2.1.3.2.tar.gz 19720 BLAKE2B 930f6aded2b42bb49b7b7865d64ff21923f720d15b375b018621fc1647cc0588226308e7c362d436f22074782a0e55ce7851fffbd47db1ea9c17f197e39c7e15 SHA512 51c3c60a56390b2c9662bf54a72a485ab0fa17872cd4163785c20b72fe4cc70b7a019214c1474d720e13e91eff807f0497d50bfaf5f3ce4f52a1bd488090b041
diff --git a/dev-python/xstatic-patternfly-bootstrap-treeview/metadata.xml b/dev-python/xstatic-patternfly-bootstrap-treeview/metadata.xml
new file mode 100644
index 000000000000..8768d46bf628
--- /dev/null
+++ b/dev-python/xstatic-patternfly-bootstrap-treeview/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">XStatic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/xstatic-patternfly-bootstrap-treeview/xstatic-patternfly-bootstrap-treeview-2.1.3.2.ebuild b/dev-python/xstatic-patternfly-bootstrap-treeview/xstatic-patternfly-bootstrap-treeview-2.1.3.2.ebuild
new file mode 100644
index 000000000000..5d71669b7da3
--- /dev/null
+++ b/dev-python/xstatic-patternfly-bootstrap-treeview/xstatic-patternfly-bootstrap-treeview-2.1.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="XStatic-Patternfly-Bootstrap-Treeview"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XStatic-Patternfly-Bootstrap-Treeview package"
+HOMEPAGE="https://pypi.org/project/XStatic-Patternfly-Bootstrap-Treeview"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/xstatic[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install() {
+ distutils-r1_python_install
+ find "${ED}" -name '*.pth' -delete || die
+}