summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-11-26 09:10:44 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-11-26 09:11:01 -0600
commit76e7a21981368a77cbcdb198a91d63baebc1760e (patch)
tree2f30266fc7c7534417b8ef89678b8e907a00f00c /dev-python
parentdev-db/mysql: arm stable wrt bug #671516 (diff)
downloadgentoo-76e7a21981368a77cbcdb198a91d63baebc1760e.tar.gz
gentoo-76e7a21981368a77cbcdb198a91d63baebc1760e.tar.bz2
gentoo-76e7a21981368a77cbcdb198a91d63baebc1760e.zip
dev-python/cryptography: add missing pycparser dep
Fixes: https://bugs.gentoo.org/671948 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/cryptography-2.2.2-r1.ebuild3
-rw-r--r--dev-python/cryptography/cryptography-2.3.1.ebuild1
-rw-r--r--dev-python/cryptography/cryptography-2.3.ebuild3
3 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/cryptography/cryptography-2.2.2-r1.ebuild b/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
index 449719f769ca..e4d73ba997e1 100644
--- a/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
+++ b/dev-python/cryptography/cryptography-2.2.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -42,6 +42,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ dev-python/pycparser[${PYTHON_USEDEP}]
test? (
~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
diff --git a/dev-python/cryptography/cryptography-2.3.1.ebuild b/dev-python/cryptography/cryptography-2.3.1.ebuild
index 1a58e5692ef8..9c239e0ef880 100644
--- a/dev-python/cryptography/cryptography-2.3.1.ebuild
+++ b/dev-python/cryptography/cryptography-2.3.1.ebuild
@@ -41,6 +41,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ dev-python/pycparser[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (
diff --git a/dev-python/cryptography/cryptography-2.3.ebuild b/dev-python/cryptography/cryptography-2.3.ebuild
index ec123a175ee9..f858938c524b 100644
--- a/dev-python/cryptography/cryptography-2.3.ebuild
+++ b/dev-python/cryptography/cryptography-2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,6 +41,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ dev-python/pycparser[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (