summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 11:20:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 11:59:05 +0200
commit7951882c1e3846bcccc43da24d4ff0647cef0888 (patch)
treecc9140cd55bc67f28e8ec84a735f323374089e28 /dev-python
parentdev-python/asttokens: Bump to 2.0.7 (diff)
downloadgentoo-7951882c1e3846bcccc43da24d4ff0647cef0888.tar.gz
gentoo-7951882c1e3846bcccc43da24d4ff0647cef0888.tar.bz2
gentoo-7951882c1e3846bcccc43da24d4ff0647cef0888.zip
dev-python/trove-classifiers: Bump to 2022.8.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2022.8.7.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index da224792d4c0..0936b8e2156a 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,3 +1,4 @@
DIST trove-classifiers-2022.6.23.gh.tar.gz 14950 BLAKE2B 7203b8edb6f8a8886371a60f3c273b02b7fe045230a3a0c89a7282a896e513535a47fe06834fd6e33b98c480695b69be524dea1402f463f3c82fc80ddf8ac320 SHA512 c2c186b5d13f626a43f29a1eff6ebf2f17f8240af554f27ffdf05b506d428dd59582e7357a85b62f94714e024ae98ea216487726526639371c24c6b46b96df4e
DIST trove-classifiers-2022.6.26.gh.tar.gz 14966 BLAKE2B 360a8a01d710456a7edf2f56ce5ca4645e0f5e79db09087a888556e6555a15fd6f6b0aa3112bf0f6c2652759fce93e76357775ca57e53615dd99c4f1b929303d SHA512 1857d53e7731ada3ca811222bab2d0734da0e18fdf36dcada166bd15b1f397cf8575963d8432eb2d0de571646da6b0b18299af3bb7e44fb225586aa76f6de35f
DIST trove-classifiers-2022.7.22.gh.tar.gz 14999 BLAKE2B ba6647b8ccb0a8a791d91c48094f3a748866c7f80f92b28903bd09084b7a216b2ba824657ba5f8ef8988edf242140c0b449804f58d3c1522e857670a1f01d455 SHA512 7d60a18a7ee11e21021f5ccc131e9ca28769083776898d931dd92131ea7edecd7ecad17a7a9d6d2d11e19ab8ff6a6fc2373ff9938fc26567e0f7c4a0e903d3c1
+DIST trove-classifiers-2022.8.7.gh.tar.gz 14999 BLAKE2B e5ec3b122f357e61c62ef9d6bbb16addeeb59aad5d5bced9d7fa2325c545298c9e3fcf619c5b459b2734caa34f2e7281d1b0306b1832c9156223d94ba83a2206 SHA512 61b776e2c4cb79788a14c17cf10f3cafaa3364bce3927e0e328b2129b65efdac9948e54d74e4454df3a094b25e6eb23074b577c5eb5735cc1939342f5c5d06ce
diff --git a/dev-python/trove-classifiers/trove-classifiers-2022.8.7.ebuild b/dev-python/trove-classifiers/trove-classifiers-2022.8.7.ebuild
new file mode 100644
index 000000000000..964617661415
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2022.8.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}