summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-15 07:37:22 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-15 07:37:22 -0400
commit7e77a6c9e10de114be5552b01deaeeb955da4277 (patch)
tree1ff511ec97890514d955e76a735351a11ae27401 /dev-python
parentgtk-sharp-module.eclass: Remove (diff)
downloadgentoo-7e77a6c9e10de114be5552b01deaeeb955da4277.tar.gz
gentoo-7e77a6c9e10de114be5552b01deaeeb955da4277.tar.bz2
gentoo-7e77a6c9e10de114be5552b01deaeeb955da4277.zip
dev-python/beautifulsoup: bump to 4.6.3
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/beautifulsoup/Manifest1
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.6.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
index 1f76d7e90328..3b47608c8bce 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup/Manifest
@@ -1,3 +1,4 @@
DIST BeautifulSoup-3.2.1.tar.gz 31224 BLAKE2B 9361ce6d048d0443c3257d10ec2734c24202af8eb850a59a4344e6992856f849d92dd509f102c27cdf9634bbc235e5f96e304993e6d4813d275d66bd3791b451 SHA512 365b7b045a2069cf437877543577bc0aa99256a6dc4c9743670b46bfceab5494a06628012d6eccecfe99c25d5c9e0c65814964b47026f15ba1a538444cfb7789
DIST beautifulsoup4-4.5.1.tar.gz 158039 BLAKE2B 5eb99c7efdb13c359385c7c7f3280332ca28cc4b5ff80b90c326d80ef55acef8e98d86691a7b1df420bf68bc65e96ad7d559b461a03f44e494fb4b7789753601 SHA512 d560d7f743507084ec546708d29bb3764512f5b2c380004280dde813350bf48d1697fddce3bd3f95186407bf5142941d7adc7d0de8e7962eb5ca1278dbc7e93f
DIST beautifulsoup4-4.6.0.tar.gz 160846 BLAKE2B c56c61c5ac2116721815b3cc8e0ec249f191a76bc36e26593af54cc0937e3a4d70c5a2b3069b12f1ae4f5b78cda78e2abda5da99fdd6987afe0f581a4130685c SHA512 1a7eee4218e58cc3852e71fe4f0892f673bb46a851941264766a38eff8ef05d612d88b4641fcb478ce8f66ac50dc987ca039923c4bbb11867c74813289f7e578
+DIST beautifulsoup4-4.6.3.tar.gz 167469 BLAKE2B 0bc8f729298a2fd1e8f3cc8a7635587217f9a2e6e2c71709e99c40eedf1ebb4d76cd0d17ec36b99f3ee047193e4d44e31b8d2aa9864c43ce5db380fbdc083f76 SHA512 0cacae77843326ebee87d108b6706a7ca6943684bcccc62554d2ae5d77dfd181c97435ceca9d3e2e51962b024bbe52bc08d7f0dc516311aa87b3a1f87fb4ae23
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.6.3.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.6.3.ebuild
new file mode 100644
index 000000000000..8ae9560e9941
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.6.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+# html5lib is optional however hard coding since its use is actively discouraged in the devmanual
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7 pypy)
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}