summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-10 18:29:03 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-10 20:29:12 -0500
commit7ff55588176b671505df62754723d4d7dd24c598 (patch)
tree756ba5f263cdb14745c2ad46b32c509b1cfcb495 /dev-python
parentdev-python/oslo-config: 8.3.2 bump (diff)
downloadgentoo-7ff55588176b671505df62754723d4d7dd24c598.tar.gz
gentoo-7ff55588176b671505df62754723d4d7dd24c598.tar.bz2
gentoo-7ff55588176b671505df62754723d4d7dd24c598.zip
dev-python/oslo-i18n: 5.0.1 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oslo-i18n/Manifest1
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index 5800177893a9..f5fc0a8e29b4 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1 +1,2 @@
DIST oslo-i18n-3.23.1.tar.gz 44731 BLAKE2B 2205d5f27640fe15c7143df2e18d27b01a3f90c30b04b838643d33cc490cc4257cde77925d76fefd0add0d3159ee4976281608b6e43288f0c0cd4fc4c7959b47 SHA512 82ebcf54d7edbd7c3e7c1d7e13b223ca9cf88aae717ee6fa0c2fb9b423ef88403b42b3360cfd7b8dd3b6d973a077a1458fc9c879efbb6006a1cedc6ade35397b
+DIST oslo-i18n-5.0.1.tar.gz 44636 BLAKE2B 69df723bff7a279ace2a8bb2ea795e6beaa626ffc4bb364c513d16d2ce3cb07f6e9957a98d1b633f95154672d118de6fbb71ef5c1a3a53520f4d1f4b8f72748f SHA512 d55238616dc90f85ff458fc6680b3a3b2493d2a640bf5849c19cd7271e7127b535a301ed3085b5e0131b46a635b5a09423f6cba60f9f1b9b0352a0e7115a8057
diff --git a/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild b/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
new file mode 100644
index 000000000000..43a19397e95f
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-5.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"