summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-11-20 19:59:00 +0100
committerSebastian Pipping <sping@gentoo.org>2016-11-20 20:00:36 +0100
commit80904f6d9d0109daf6f656cd450edfda4b8de402 (patch)
tree3bbfe39b4481b11ba79096eb066202510f652e0b /dev-python
parentnet-analyzer/ntopng: Patch to use CC/CXX variables (diff)
downloadgentoo-80904f6d9d0109daf6f656cd450edfda4b8de402.tar.gz
gentoo-80904f6d9d0109daf6f656cd450edfda4b8de402.tar.bz2
gentoo-80904f6d9d0109daf6f656cd450edfda4b8de402.zip
dev-python/pip: 9.0.1 (bug #590828)
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pip/Manifest1
-rw-r--r--dev-python/pip/files/pip-9.0.1-disable-version-check.patch32
-rw-r--r--dev-python/pip/pip-9.0.1.ebuild80
3 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index b5837706324a..ea8fe00fc1d9 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -3,3 +3,4 @@ DIST pip-8.0.2.tar.gz 1130183 SHA256 46f4bd0d8dfd51125a554568d646fe4200a3c2c6c36
DIST pip-8.0.3.tar.gz 1131758 SHA256 30f98b66f3fe1069c529a491597d34a1c224a68640c82caf2ade5f88aa1405e8 SHA512 744111288dd86580e55a4eaeebcaab7b5fdd9e2ea47500e3febe2ce0a282b074f0c687d40a764b98bc54e0bf50748506eb8a5e220a095f2fe655f5cb42ba47c1 WHIRLPOOL 5bd7824ae4a311d98e47ccbf5fcc65b06579d30c0baa58357838935fd2646e87a610e76b22704b20d0c9379c321b878b409639e3604e725f2f08f83a8d7f1dda
DIST pip-8.1.1.tar.gz 1139175 SHA256 3e78d3066aaeb633d185a57afdccf700aa2e660436b4af618bcb6ff0fa511798 SHA512 3b8f629ca19bff627317415ca681a5ea12171be57a04347e83dcee4a4d013ff9db47beddd56bded1856d4f0ae1a075d901140fe04f544df8018f066d812c0f28 WHIRLPOOL f5ae76d3e2b6807aee5c2af03a2c83a18ae12182a8a533bc50e16ca07eb5efa1f7181d90ffcab171a687ace6880ddd8149b95a003ba749d21ae00ce1b0601891
DIST pip-8.1.2.tar.gz 1140573 SHA256 4d24b03ffa67638a3fa931c09fd9e0273ffa904e95ebebe7d4b1a54c93d7b732 SHA512 f35e70344bc7baa0739d7a8a38e51f401774b23672e915c32d54fab3e9cc465bfc47361823fa75d2a64fc8748f2020170bd7a4cfde10070d7febf56d1f9124f0 WHIRLPOOL b1b9d46d39b03f78cbceccfd27416dcc50189accefc2a5a6e7a002c9930d7299897d1d15726b95c400c2495ce23c4db414ad8aa29424f189b8be33470a96f12a
+DIST pip-9.0.1.tar.gz 1197370 SHA256 09f243e1a7b461f654c26a725fa373211bb7ff17a9300058b205c61658ca940d SHA512 ee59efb4b009ff6543b7afdea99b9cbbee1981ecc03af586acda76674024d3b66dab23049e68f3da9448734984619fc1eaba6e965c9dd3d731973376c8a42e25 WHIRLPOOL c97a5e9d03943437873d3a49166c28bccf3e0d1f9efe8f500a730607bffcfc26184a6785f1ee55b6867bc4dbd0e77334da7dcf22bd6ba9ae26949c76b6a1c734
diff --git a/dev-python/pip/files/pip-9.0.1-disable-version-check.patch b/dev-python/pip/files/pip-9.0.1-disable-version-check.patch
new file mode 100644
index 000000000000..7334380c1e1d
--- /dev/null
+++ b/dev-python/pip/files/pip-9.0.1-disable-version-check.patch
@@ -0,0 +1,32 @@
+From 890a1c26018752f2c57c7800968e4b8d1e0987f9 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 20 Nov 2016 19:52:40 +0100
+Subject: [PATCH] Stop checking for new versions
+
+---
+ pip/basecommand.py | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/pip/basecommand.py b/pip/basecommand.py
+index 54c6706..3cffe86 100644
+--- a/pip/basecommand.py
++++ b/pip/basecommand.py
+@@ -241,15 +241,6 @@ class Command(object):
+ logger.critical('Exception:', exc_info=True)
+
+ return UNKNOWN_ERROR
+- finally:
+- # Check if we're using the latest version of pip available
+- if (not options.disable_pip_version_check and not
+- getattr(options, "no_index", False)):
+- with self._build_session(
+- options,
+- retries=0,
+- timeout=min(5, options.timeout)) as session:
+- pip_version_check(session)
+
+ return SUCCESS
+
+--
+2.10.2
+
diff --git a/dev-python/pip/pip-9.0.1.ebuild b/dev-python/pip/pip-9.0.1.ebuild
new file mode 100644
index 000000000000..8cd1b05c63d7
--- /dev/null
+++ b/dev-python/pip/pip-9.0.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit eutils bash-completion-r1 distutils-r1
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="https://pip.pypa.io/ https://pypi.python.org/pypi/pip/ https://github.com/pypa/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+# Check pip/_vendor/vendor.txt for this
+#VENDOR_DEPEND="
+# >=dev-python/distlib-0.2.2[${PYTHON_USEDEP}]
+# >=dev-python/html5lib-1.0b8[${PYTHON_USEDEP}]
+# >=dev-python/six-1.10.0${PYTHON_USEDEP}]
+# >=dev-python/colorama-0.3.6[${PYTHON_USEDEP}]
+# >=dev-python/requests-2.9.1-r2[${PYTHON_USEDEP}]
+# >=dev-python/CacheControl-0.11.6[${PYTHON_USEDEP}]
+# >=dev-python/lockfile-0.12.2[${PYTHON_USEDEP}]
+# >=dev-python/progress-1.2[${PYTHON_USEDEP}]
+# >=dev-python/packaging-16.5[${PYTHON_USEDEP}]
+# >=dev-python/retrying-1.3.3[${PYTHON_USEDEP}]
+# >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+# virtual/python-ipaddress[${PYTHON_USEDEP}]
+#"
+# https://github.com/pypa/pip/issues/3057
+#RDEPEND="${VENDOR_DEPEND}
+# >=dev-python/setuptools-19.2[${PYTHON_USEDEP}]
+# <dev-python/setuptools-19.4[${PYTHON_USEDEP}]
+#"
+#DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+#PATCHES=(
+# "${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch
+# "${FILESDIR}"/${PN}-8.0.0-unbundle.patch
+# )
+
+#python_prepare_all() {
+# mv pip/_vendor/__init__.py "${T}" || die
+# rm -r pip/_vendor/* || die
+# mv "${T}"/__init__.py pip/_vendor/__init__.py || die
+#
+# distutils-r1_python_prepare_all
+#}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-9.0.1-disable-version-check.patch
+
+ distutils-r1_src_prepare
+ eapply_user
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ "${PYTHON}" -m pip completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ "${PYTHON}" -m pip completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}