summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-24 14:55:43 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 08:00:02 +0200
commit80a39d9fcf9036ccfe8dafe4a7f4bea3eb4b3c58 (patch)
tree88b8acbc603ab9f9551c0eaf88c1eab5a78a4f36 /dev-python
parentsys-auth/polkit: arm stable, bug #554878 (diff)
downloadgentoo-80a39d9fcf9036ccfe8dafe4a7f4bea3eb4b3c58.tar.gz
gentoo-80a39d9fcf9036ccfe8dafe4a7f4bea3eb4b3c58.tar.bz2
gentoo-80a39d9fcf9036ccfe8dafe4a7f4bea3eb4b3c58.zip
dev-python/cffi: Add back version so that sparc is happy
Package-Manager: portage-2.2.21 RepoMan-Options: --force Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-0.8.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 1db4dd121213..c4cd18abae1d 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1,3 +1,4 @@
+DIST cffi-0.8.6.tar.gz 196835 SHA256 2532d9e3af9e3c6d0f710fc98b0295b563c7f39cfd97dd2242bd36fbf4900610 SHA512 b913d459bf0d355f0cb42fa0587a940c227d6765450033b14ab4d5281173cd1875cd6872911bb4f0b567cc1c5b0ca330615ec5f6ba205b25c41b683ae8c77790 WHIRLPOOL 4a03a077f15f943e0f06acf1bc10572b19680379e36805dbfc3dfffb8a5d735d28d9bab38e2d233f3a347fc03cede8126cc2ce017c6e3a0896b9baecddfae39f
DIST cffi-0.9.2.tar.gz 209160 SHA256 1988ce7ff9c64ecd5077776175e90fd8f0a8c827cb241a23647175ce08126bb2 SHA512 93371a1189955d3f794915f8e7c6f6b9ab36cd531ff0ddeeb2108364c94dbf4dbe5d7d3f75e0aa52576d1a59559c13ec3e0f68dec4d52e6221e683ac519b850c WHIRLPOOL dcdf3a35b35607a4982035e75332c0e2f87d2df5cca9df77c48c5d57cc783d341b77fd95f71681877695b03a12564f8f28717a975bd51e832f496b71f73c3736
DIST cffi-1.1.2.tar.gz 326758 SHA256 390970b602708c91ddc73953bb6929e56291c18a4d80f360afa00fad8b6f3339 SHA512 d146984013b63382ea64bd2d6188cdbf9154cf83d66bf4dbb9353f1daea66f9eae07c6da47e152c5758d3458a742adde0310f71c792eb0a80950d7f857bfb943 WHIRLPOOL 02b92f0d13b02e351ba63e55a731c0b5480ae0b376c99a8dc1a256b3b55bf0119b4238dca88171605c1348b0847a6ff305ba4ec69cd1b42b9950708f42d6067e
DIST cffi-1.2.1.tar.gz 335778 SHA256 eab571deb0a152e2f53c404c08a94870a131526896cad08cd43bf86ce3771e3d SHA512 26ab695d34ef1895f38c735b2c6400cbf6325d622ce93799513130791365bb71d656288e991b86861ac8e899872504c1f4368d27104c4ac9b881c83c7f8dad88 WHIRLPOOL a8bbe3c24be660946c1f31fbb8b1f50810f78b9485a32aadfb091a624b5386641bde71981c58792f8e95e8e77cfce7d9959eb197c417464cf5351e568aa6336d
diff --git a/dev-python/cffi/cffi-0.8.6.ebuild b/dev-python/cffi/cffi-0.8.6.ebuild
new file mode 100644
index 000000000000..a7862a668f48
--- /dev/null
+++ b/dev-python/cffi/cffi-0.8.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc"
+
+RDEPEND="virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/build/
+}