summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-14 11:53:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-14 13:09:58 +0200
commit81ffdca3af163e42650cf1c1dd21dac0c84f4014 (patch)
treeeb382426bd652b39362c0faf0399aeac82878950 /dev-python
parentdev-python/jsonpatch: Port to py3.9 (diff)
downloadgentoo-81ffdca3af163e42650cf1c1dd21dac0c84f4014.tar.gz
gentoo-81ffdca3af163e42650cf1c1dd21dac0c84f4014.tar.bz2
gentoo-81ffdca3af163e42650cf1c1dd21dac0c84f4014.zip
dev-python/networkx: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/networkx/files/networkx-2.4-py39.patch46
-rw-r--r--dev-python/networkx/networkx-2.4-r1.ebuild3
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/networkx/files/networkx-2.4-py39.patch b/dev-python/networkx/files/networkx-2.4-py39.patch
new file mode 100644
index 000000000000..7efe8998b35f
--- /dev/null
+++ b/dev-python/networkx/files/networkx-2.4-py39.patch
@@ -0,0 +1,46 @@
+From 0cb12b33df48788c10fa21b326803ae66d74cbe6 Mon Sep 17 00:00:00 2001
+From: Jarrod Millman <jarrod.millman@gmail.com>
+Date: Mon, 21 Oct 2019 00:56:04 -0700
+Subject: [PATCH] Remove unused imports
+
+---
+ .travis.yml | 3 ---
+ networkx/algorithms/assortativity/connectivity.py | 2 --
+ networkx/algorithms/assortativity/correlation.py | 13 ++++++-------
+ networkx/algorithms/assortativity/mixing.py | 1 -
+ .../algorithms/assortativity/neighbor_degree.py | 1 -
+ networkx/algorithms/assortativity/pairs.py | 1 -
+ networkx/algorithms/cluster.py | 1 -
+ networkx/algorithms/community/modularity_max.py | 1 -
+ networkx/algorithms/components/biconnected.py | 1 -
+ networkx/algorithms/isolate.py | 1 -
+ networkx/algorithms/isomorphism/isomorphvf2.py | 1 -
+ networkx/algorithms/traversal/beamsearch.py | 1 -
+ networkx/classes/graph.py | 2 +-
+ networkx/classes/reportviews.py | 1 -
+ networkx/conftest.py | 8 ++++++--
+ networkx/linalg/attrmatrix.py | 1 -
+ networkx/readwrite/gexf.py | 11 ++---------
+ networkx/readwrite/gpickle.py | 1 -
+ networkx/readwrite/graphml.py | 11 ++---------
+ networkx/readwrite/nx_yaml.py | 1 -
+ networkx/readwrite/tests/test_graphml.py | 4 ++--
+ tools/travis/script.sh | 2 +-
+ 22 files changed, 20 insertions(+), 49 deletions(-)
+
+diff --git a/networkx/readwrite/tests/test_graphml.py b/networkx/readwrite/tests/test_graphml.py
+index 00b97d77..1946c487 100644
+--- a/networkx/readwrite/tests/test_graphml.py
++++ b/networkx/readwrite/tests/test_graphml.py
+@@ -879,7 +879,7 @@ class TestWriteGraphML(BaseGraphML):
+
+ xml = parse(fh)
+ # Children are the key elements, and the graph element
+- children = xml.getroot().getchildren()
++ children = list(xml.getroot())
+ assert len(children) == 3
+
+ keys = [child.items() for child in children[:2]]
+--
+2.27.0
+
diff --git a/dev-python/networkx/networkx-2.4-r1.ebuild b/dev-python/networkx/networkx-2.4-r1.ebuild
index fa234268a45d..94c1dbe4890d 100644
--- a/dev-python/networkx/networkx-2.4-r1.ebuild
+++ b/dev-python/networkx/networkx-2.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 virtualx
DESCRIPTION="Python tools to manipulate graphs and complex networks"
@@ -39,6 +39,7 @@ distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}"/${P}-py38.patch
+ "${FILESDIR}"/${P}-py39.patch
)
src_prepare() {