summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-20 21:36:21 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-20 21:36:21 +0200
commit84e1f8662c57f2a5f30fdd1b6f9ce42ca013d498 (patch)
tree410f54f41f6a11a1f52072ee12e4fbcc257c54db /dev-python
parentdev-python/flask-debug: support PyPy{,3}, Python 3.6, fix deps (diff)
downloadgentoo-84e1f8662c57f2a5f30fdd1b6f9ce42ca013d498.tar.gz
gentoo-84e1f8662c57f2a5f30fdd1b6f9ce42ca013d498.tar.bz2
gentoo-84e1f8662c57f2a5f30fdd1b6f9ce42ca013d498.zip
dev-python/dominate: add PyPy{,3}
Remove pytest-runner from test DEPENDs, it is not required. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dominate/dominate-2.3.1.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/dominate/dominate-2.3.1.ebuild b/dev-python/dominate/dominate-2.3.1.ebuild
index d149b940eab5..a66dafe92b1a 100644
--- a/dev-python/dominate/dominate-2.3.1.ebuild
+++ b/dev-python/dominate/dominate-2.3.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
inherit distutils-r1
@@ -17,10 +17,7 @@ IUSE="test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
python_test() {