summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-12-08 19:47:42 +0100
committerMichael Weber <xmw@gentoo.org>2017-12-08 19:47:56 +0100
commit8911338c909f63cd5f665f040b6cbd920f45cdc1 (patch)
tree6a0fdb0fcadf082e423056749c3ead1b78fad44f /dev-python
parentdev-tcltk/tcllib: [QA] Move patches to distfiles (diff)
downloadgentoo-8911338c909f63cd5f665f040b6cbd920f45cdc1.tar.gz
gentoo-8911338c909f63cd5f665f040b6cbd920f45cdc1.tar.bz2
gentoo-8911338c909f63cd5f665f040b6cbd920f45cdc1.zip
dev-python/pyClamd: Version bump (bug 639546).
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyClamd/Manifest3
-rw-r--r--dev-python/pyClamd/pyClamd-0.4.0.ebuild26
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-python/pyClamd/Manifest b/dev-python/pyClamd/Manifest
index 48ca1759b6d4..3108b463f1eb 100644
--- a/dev-python/pyClamd/Manifest
+++ b/dev-python/pyClamd/Manifest
@@ -1,2 +1,3 @@
DIST pyClamd-0.3.10.tar.gz 8929 SHA256 ed77743c32298b151c881cc52a211e188bd24203ae402f2640def858c6a2bca7 SHA512 2c895fbc5897646ad5c23445062fb2e34a2db070471afd8356796f5f458d90b0da824af58b8ba762ce49572acaee6981881169eb33231085dac82ff0169fa2c8 WHIRLPOOL fa9ba64ab721169373572e552450fcee96db0499a9eeb336763ed2ea9e6f24328aece3b46a2c04ba2a6706f8d6a047ea0ef96f1fe53a6ae4663be0980d9e9c43
-DIST pyClamd-0.3.17.tar.gz 10737 SHA256 9921a582c45baa34dabb357c548c5ed331b9a39334881b3a784b593680b07ba0 SHA512 52eda3f5b6612d47b803e6df8a49890167805dc39a30004f979dcd828b2717ebf7fe753ad0305ab3aad00aaaf750e9e862d43a504ccdb8f7df6faceae18da4a8 WHIRLPOOL 4e3f729f30ea65e0f57131087063405efe57b4b54b081cdb84eb9ccdfd77457f2ddb02d47e2ee79a68179eea27cfabfa3d700dd398f0dd21b4aa4663cbe051c4
+DIST pyClamd-0.3.17.tar.gz 10737 BLAKE2B a190809b8f652fdff6c55c73a9431fa509219b9a8d8728ac63844ab1d88e9169df8eeef96892695a8c8a60c48c7fbf938d347603676a186746c4be202b37ef34 SHA512 52eda3f5b6612d47b803e6df8a49890167805dc39a30004f979dcd828b2717ebf7fe753ad0305ab3aad00aaaf750e9e862d43a504ccdb8f7df6faceae18da4a8
+DIST pyClamd-0.4.0.tar.gz 11177 BLAKE2B cb69c9e1fec936d416a18658a2c3e9df4dc4684cf56c19e8a02ad9929b4c86d9985395c38a8f88f7053f81fe08fa3574c6a206bcc519a9494c2a61caf6b995b1 SHA512 b96e26729e0fe2600572534c0fa22a01238761589f1771e72a054dde9c1b8f122493c83ca04cffda167f7a0e44fbf309bdf76b8fe1de499ec50d56c677923bd4
diff --git a/dev-python/pyClamd/pyClamd-0.4.0.ebuild b/dev-python/pyClamd/pyClamd-0.4.0.ebuild
new file mode 100644
index 000000000000..9f78b67269f2
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="http://xael.org/pages/pyclamd-en.html"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -e 's:/etc/clamav/clamd.conf:/etc/clamd.conf:' \
+ -i pyclamd/pyclamd.py || die
+}