summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-09 09:09:40 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-09 09:14:50 +0100
commit8ae39372d750788337992a2aeee6b49d3423defb (patch)
tree4be7f3b9832ef15b2a15a6d52c9d329089f607b1 /dev-python
parentdev-python/keep: version bump 2.10 (diff)
downloadgentoo-8ae39372d750788337992a2aeee6b49d3423defb.tar.gz
gentoo-8ae39372d750788337992a2aeee6b49d3423defb.tar.bz2
gentoo-8ae39372d750788337992a2aeee6b49d3423defb.zip
dev-python/sortedcontainers: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sortedcontainers/Manifest1
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sortedcontainers/Manifest b/dev-python/sortedcontainers/Manifest
index 5f453bad5fcf..8963ca2c913f 100644
--- a/dev-python/sortedcontainers/Manifest
+++ b/dev-python/sortedcontainers/Manifest
@@ -1 +1,2 @@
DIST python-sortedcontainers-2.2.2.gh.tar.gz 9228894 BLAKE2B 358a2028a00748c89046069ed7ff075350d4a93f98521b48a72ba466719fd8b1eaa023f4c9d93beec1538315518f7fcc8b5b02478b1506c65fafa3840081b668 SHA512 413212aa35a80d24ec208caf19314dcc42dae207ec4ea8fdd7dc240c6fbf17372cb4c3e2209f6e40094419fa3eeb2fc9b23ad8bd7fb4e6fdaca46fd2fb248281
+DIST python-sortedcontainers-2.3.0.gh.tar.gz 9228968 BLAKE2B cdff8230d4e4ac42a89ed3192666ebf22cd48a4475f1dc173cffb0339c7f27e9cdfde1fb631daadf04adf2c00bed8a924e1202712d0ebcbd591f5542de863461 SHA512 0488e2f9f07ea7e4737ade69441f02614b63cfccb32a71af4e5953001bfa840d2e113a36a0a0a6d4c1e7fdd920ac3937b0baaea522d742547a4d81a99b8d1a6c
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild
new file mode 100644
index 000000000000..3ca102a10999
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-2.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/
+ https://pypi.org/project/sortedcontainers/
+ https://github.com/grantjenks/python-sortedcontainers/"
+SRC_URI="
+ https://github.com/grantjenks/python-sortedcontainers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH=.
+ pytest -vv --ignore docs/conf.py || die "Tests fail with ${EPYTHON}"
+}