summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-11 09:11:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-11 12:46:55 +0200
commit8c21a56517af21f96da3ffbabce32c73c5e368f6 (patch)
tree2c5c8dd54be2bc4e9266ad5fa8a4a6eb3f6515f3 /dev-python
parentRename dev-python/{PyICU → pyicu} (diff)
downloadgentoo-8c21a56517af21f96da3ffbabce32c73c5e368f6.tar.gz
gentoo-8c21a56517af21f96da3ffbabce32c73c5e368f6.tar.bz2
gentoo-8c21a56517af21f96da3ffbabce32c73c5e368f6.zip
dev-python/pyicu: Bump to 2.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/metadata.xml1
-rw-r--r--dev-python/pyicu/pyicu-2.7.1.ebuild28
3 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index a364e5a1c082..611ddaa1ad2b 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1 +1,2 @@
DIST PyICU-2.6.tar.gz 233826 BLAKE2B 318b87b878f8d49f47f48780567751671f5f88902c4cae9a243a81300b002ca6ea2336aee38bfc76a3037326f15f197fd71819173b678c68094d16f8db51864e SHA512 ab4c167cbeb80a23904476e51a3c16aa4721e26840b1d4c2f44b5a610e5467a6880c45f27636efb9e44e8e4302a095d437f4868409103270d79ecd56a3d90c9c
+DIST pyicu-v2.7.1.tar.bz2 238508 BLAKE2B 20fed10bde607effc4d7f5e3882508e2673b4def29417fb888853565ddbbd3de22db986bf9801b8886570e080e1b50a2d941d18fcb39587fdf9a4e6bd5afefb0 SHA512 9d6a0c713396e0391a8617e68ad5ec5410e2dbb7ea0decad02816530ecc5a5ce8dc6b0ef905107b45f0e62c9d60e1e0d565ad18aeaf92e38fefd1c123e8754b5
diff --git a/dev-python/pyicu/metadata.xml b/dev-python/pyicu/metadata.xml
index cc32deae1d97..e42277dbda05 100644
--- a/dev-python/pyicu/metadata.xml
+++ b/dev-python/pyicu/metadata.xml
@@ -10,7 +10,6 @@
<name>Python</name>
</maintainer>
<upstream>
- <remote-id type="github">ovalhub/pyicu</remote-id>
<remote-id type="pypi">PyICU</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pyicu/pyicu-2.7.1.ebuild b/dev-python/pyicu/pyicu-2.7.1.ebuild
new file mode 100644
index 000000000000..98aecea4d8c8
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/icu:="
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest