summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-02-22 14:27:27 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-02-22 14:27:27 +0100
commit90bba8a7c8cb33fd3d7cadb89f6fb5ffdf351f74 (patch)
treef14cea645ed63c5c5ee56cf91bd567b224f9eede /dev-python
parentdev-util/drone: Remove old (diff)
downloadgentoo-90bba8a7c8cb33fd3d7cadb89f6fb5ffdf351f74.tar.gz
gentoo-90bba8a7c8cb33fd3d7cadb89f6fb5ffdf351f74.tar.bz2
gentoo-90bba8a7c8cb33fd3d7cadb89f6fb5ffdf351f74.zip
dev-python/prometheus_client: Version bump to 0.6.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.6.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index 971cc07fdd5a..a79671899f40 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1,2 +1,3 @@
DIST prometheus_client-0.4.2.tar.gz 57664 BLAKE2B e98e5c91db13a9f06c2df532e7742545a14cb223e04eba27accc3bdcaf2df949eed2a778194b38e1b4b93908de1636a3cc92a18950db54b5b8f0aceda2d4d2cf SHA512 5e0fee9f9fb4376dcf2959e8285b57a9156d3cf8b9d9118c7b95d2ff63f4dd925bc8cea817bf2fc1ba660e6f5c6dd8f4cf494125cf2a3673443abe0f3a4657c4
DIST prometheus_client-0.5.0.tar.gz 60184 BLAKE2B cc44537b051c053860520d412664d57aaa6d35dd491409de0da72b9859743cc355d67eb260c2381347ad3313df9efa498535ff130df317b103d8c815f34f28eb SHA512 6e6e6c0f859b7b9d593e1059b71fde8eed15ccd95e54c245b4e0e8edb748a4761f0929f2d6c06f1c4656eb81f26959c5cec6a58f4d725a587b433ffbb4582127
+DIST prometheus_client-0.6.0.tar.gz 60790 BLAKE2B fa8eaddfedb9598394fec0c6464499ed5bcace9969e843126422414e397d31985a44a626be0257a235f6d5f685fd8d6bb55fc0d92928f0b9729ab9f097f1958b SHA512 a2b92683f939961c567c266a54699de6f37088cd4e61c9d9a5f4451228b4c3bfa4c517e4a5187867f5463d726a8dc6e7fdae30973c1e9aa9aa1a03247b2e99cd
diff --git a/dev-python/prometheus_client/prometheus_client-0.6.0.ebuild b/dev-python/prometheus_client/prometheus_client-0.6.0.ebuild
new file mode 100644
index 000000000000..9e70c4e5396d
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus_client/"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted[${PYTHON_USEDEP}] dev-python/twisted-web[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -v || die
+}