summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-01 14:35:28 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-01 14:35:28 +0100
commit9181775cc513c8de1be3b88d171ae7068389f890 (patch)
treea2eceb262eeb551c310ba7853a68d4743b449f04 /dev-python
parentdev-util/omake: Bump to 0.10.2 (diff)
downloadgentoo-9181775cc513c8de1be3b88d171ae7068389f890.tar.gz
gentoo-9181775cc513c8de1be3b88d171ae7068389f890.tar.bz2
gentoo-9181775cc513c8de1be3b88d171ae7068389f890.zip
dev-python/prometheus_client: Version bump to 0.0.19
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.0.19.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index 1f782aef3a1e..358918dd856f 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1 +1,2 @@
DIST prometheus_client-0.0.18.tar.gz 38102 SHA256 ea484439f7484af1c9137324a6cb2e920a5b9e968a66dbd02700e0329b631e6d SHA512 97291948b9ccabec7747b1059d30c7707358a95b03d278037a4d7b02ee9d3390d995425891e4c6a59ffb7aedf1f957a31093d14ac1ed254764f5768ec3a7b784 WHIRLPOOL 5e873d242c98e77612a9a5b40872f7760411e6bb7aefe5491077d5e6a778ddccb420830ae32e8ea20e39e7711c7e166a91df1e8e67968a2c454ef4d3f0156242
+DIST prometheus_client-0.0.19.tar.gz 39428 SHA256 ba85951f8183bc4992259a8117a5564652a396d236f8cda0ae70fb9aaac71ab4 SHA512 0ee5d95c27f7be5f88d462d8a851f6072af49421788c6b3e9f4f51aa5dd1ecd9324539405c1873a3becd62c0cb03bd540c0c29d8fd2115e865bf53189740b0da WHIRLPOOL 586a3ecc954c2a1e4b2d422888afe9fd7477051841d4f1c11d402261d061a04b96ff5dec5ad51f4f2704fe22b2b4f5648e5c63101338fdb6a5bcbfc2f2c35597
diff --git a/dev-python/prometheus_client/prometheus_client-0.0.19.ebuild b/dev-python/prometheus_client/prometheus_client-0.0.19.ebuild
new file mode 100644
index 000000000000..58681e0e90e9
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.0.19.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.python.org/pypi/prometheus_client"
+SRC_URI="https://github.com/prometheus/client_python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted-web dev-python/twisted[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest || die
+}